Skip to content
This repository

Enterprise: git fork: bad URI #122

Closed
HighwayofLife opened this Issue December 21, 2011 · 1 comment

2 participants

David Lewis Mislav Marohnić
David Lewis

Steps to reproduce:

$ GITHUB_HOST=github.enterprise.com git clone org/repo
Cloning into 'repo' ...
...
$ cd repo; git fork

Produces the following error...

/System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/1.8/uri/common.rb:436:in `split': bad URI(is not URI?): https://github.enterprise.com/api/v2/yaml/repos/show/highwayoflife/Bones (URI::InvalidURIError)
    from /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/1.8/uri/common.rb:485:in `parse'
    from /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/1.8/uri/common.rb:608:in `URI'
    from /usr/local/bin/hub:1305:in `http_request'
    from /usr/local/bin/hub:1225:in `repo_exists?'
    from /usr/local/bin/hub:874:in `fork'
    from /usr/local/bin/hub:603:in `send'
    from /usr/local/bin/hub:603:in `run'
    from /usr/local/bin/hub:1443:in `initialize'
    from /usr/local/bin/hub:1447:in `new'
    from /usr/local/bin/hub:1447:in `execute'
    from /usr/local/bin/hub:1496
Mislav Marohnić mislav closed this issue from a commit December 22, 2011
Mislav Marohnić ruby 1.8 fix
Closes #122
db1cacb
Mislav Marohnić mislav closed this in db1cacb December 21, 2011
Mislav Marohnić
Owner
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.