Older versions of Git fail to #rev_list silently #237

Closed
Peeja opened this Issue Sep 24, 2012 · 2 comments

Projects

None yet

2 participants

@Peeja
Contributor
Peeja commented Sep 24, 2012

I had Git 1.7.4.1 and couldn't get git pull-request to give me a default PR message. I tracked it down to #rev_list using --right-only, which doesn't exist in that version of Git.

Since Git is returning a non-zero status, it would be nice to have some sort of error or warning that would point me to trouble with Git.

Member
mislav commented Sep 24, 2012

Thanks for letting me know. I must have inadvertently raised the bar for git dependency. Otherwise hub depends on 1.7.3

I'll see about providing a better error message

Member
mislav commented Jan 22, 2016

I'm not sure what's our minimum required git version anymore, but time has passed since this was reported, and people now generally have newer git versions that support --right-only. Nobody has complained about this since, so I'm going to go ahead and close this out.

@mislav mislav closed this Jan 22, 2016
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment