Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Browse files

Bump version to v2.3.0

  • Loading branch information...
commit 768d7a84a271af8cb21f1931a08108f8f4a0828c 1 parent 3ea175e
@tombell tombell authored
Showing with 18 additions and 4 deletions.
  1. +14 −0 CHANGELOG.md
  2. +1 −1  package.json
  3. +3 −3 src/templates/package.json
View
14 CHANGELOG.md
@@ -1,3 +1,17 @@
+v2.3.0
+======
+* Extracted remaining classes into their own files - tombell
+
+**Note** this is a breaking change for adapters. Adapters are going to want to
+use the following code snippet for requiring classes from hubot.
+
+ {Adapter,Robot} = require 'hubot'
+
+* Update the formatting of documentation comments at the top of
+ scripts - technicalpickles
+
+* Update the parsing of the documentation comments - tombell
+
v2.2.0
======
* Fixed keep alive ping, requires `HEROKU_URL` - tombell and jimeh
View
2  package.json
@@ -1,6 +1,6 @@
{
"name": "hubot",
- "version": "2.2.2",
+ "version": "2.3.0",
"author": "hubot",
"keywords": "github hubot campfire bot",
"description": "A simple helpful Robot for your Company",
View
6 src/templates/package.json
@@ -1,6 +1,6 @@
{
"name": "hosted-hubot",
- "version": "2.2.0",
+ "version": "2.3.0",
"author": "GitHub Inc.",
"keywords": "github hubot campfire bot",
"description": "A simple helpful Robot for your Company",
@@ -15,8 +15,8 @@
},
"dependencies": {
- "hubot": "2.2.2",
- "hubot-scripts": ">=2.0.8",
+ "hubot": "2.3.0",
+ "hubot-scripts": ">= 2.1.0",
"optparse": "1.0.3"
},
Please sign in to comment.
Something went wrong with that request. Please try again.