Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Latest version of Jekyll (3.8.3) not compatible with latest github-pages gem (188) - Depends on Jekyll (= 3.7.3) #577

Closed
simon-spenc opened this issue Jul 18, 2018 · 8 comments

Comments

@simon-spenc
Copy link

@simon-spenc simon-spenc commented Jul 18, 2018

Before submitting an issue, please be sure to

This issue affects

  • [] The site generated by GitHub Pages
  • Building sites locally

The GitHub Pages Gem is intended to help users replicate the GitHub Pages build environment locally. If your issue affects both the hosted version and the version previewed locally, you may be better suited reporting seeking support in other forums.

What did you do (e.g., steps to reproduce)

  • I believe this issue is the same, but I wasn't sure: #555

Following the Jekyll & Github Pages instructions (with no additional gems or code) I added gem 'github-pages' , group: :jekyll_plugins' to my gem file. And then got this error after running bundle update:

Bundler could not find compatible versions for gem "jekyll":
  In Gemfile:
    github-pages was resolved to 4, which depends on
      jekyll (= 1.1.2)

    jekyll-feed (~> 0.6) was resolved to 0.10.0, which depends on
      jekyll (~> 3.3)

I then tried updating the gem file to specify the latest version of Github Pages by adding gem 'github-pages' ,'188', group: :jekyll_plugins' to the gem file and got this error:

Bundler could not find compatible versions for gem "jekyll":
  In Gemfile:
    jekyll (~> 3.8.3)

    github-pages (= 188) was resolved to 188, which depends on
      jekyll (= 3.7.3)

It seems like the version of Jekyll that I'm running (latest as I just installed Jekyll yesterday) not the right version or requires an earlier version for githup-pages gem.

What did you expect to happen?

bundle install to resolve successfully

What happened instead?

Got an error:

Bundler could not find compatible versions for gem "jekyll":
  In Gemfile:
    jekyll (~> 3.8.3)

    github-pages (= 188) was resolved to 188, which depends on
      jekyll (= 3.7.3)

Additional information

@mattr-

This comment has been minimized.

Copy link

@mattr- mattr- commented Jul 18, 2018

GitHub Pages hasn't updated to use Jekyll 3.8.3 yet. You'll be able to work with both gems by downgrading Jekyll in your Gemfile to 3.7.3.

@simon-spenc

This comment has been minimized.

Copy link
Author

@simon-spenc simon-spenc commented Jul 18, 2018

Thanks Matt - I'll close this ticket for now.

@merlinpatt

This comment has been minimized.

Copy link
Contributor

@merlinpatt merlinpatt commented Aug 11, 2018

@simon-spenc please upvote and comment on #555. It will help draw attention to it and get it updated sooner

thebillkidy added a commit to thebillkidy/thebillkidy.github.io that referenced this issue Jan 27, 2019
dnprock added a commit to bitflate/bitflate.github.io that referenced this issue Apr 14, 2019
@joshuaspy

This comment has been minimized.

Copy link

@joshuaspy joshuaspy commented Apr 16, 2019

After spent couple of hours did research on this issue, I got the solution. I took time to spent on reading the Gemfile and understood what was mentioned there. This was the error encountered:

Bundler could not find compatible versions for gem "jekyll":
  In Gemfile:
    github-pages was resolved to 4, which depends on
      jekyll (= 1.1.2)

    jekyll-feed (~> 0.6) was resolved to 0.12.1, which depends on
      jekyll (>= 3.7, < 5.0)

code from Gemfile:

source "https://rubygems.org"
  
# Hello! This is where you manage which Jekyll version is used to run.
# When you want to use a different version, change it below, save the
# file and run `bundle install`. Run Jekyll with `bundle exec`, like so:
#
#     bundle exec jekyll serve
#
# **This will help ensure the proper Jekyll version is running.**
# Happy Jekylling!
gem "jekyll", "~> 3.8.5"

# This is the default theme for new Jekyll sites. You may change this to anything you like.
gem "minima", "~> 2.0"

# If you want to use GitHub Pages, remove the "gem "jekyll"" above and
# uncomment the line below. To upgrade, run `bundle update github-pages`.
gem 'github-pages', group: :jekyll_plugins

so I just commented below line:
#gem 'github-pages', group: :jekyll_plugins

and let the bundle to fetch:
gem "jekyll", "~> 3.8.5"

then run this command:
bundle install

Issue resolved for me.

$ bundle install
The dependency tzinfo-data (>= 0) will be unused by any of the platforms Bundler is installing for. Bundler is installing for ruby but the dependency is only for x86-mingw32, x86-mswin32, x64-mingw32, java. To add those platforms to the bundle, run `bundle lock --add-platform x86-mingw32 x86-mswin32 x64-mingw32 java`.
Fetching gem metadata from https://rubygems.org/...........
Fetching gem metadata from https://rubygems.org/.
Resolving dependencies...
Using public_suffix 3.0.3
Following files may not be writable, so sudo is needed:
  /Library/Ruby/Gems/2.3.0
  /Library/Ruby/Gems/2.3.0/build_info
  /Library/Ruby/Gems/2.3.0/cache
  /Library/Ruby/Gems/2.3.0/doc
  /Library/Ruby/Gems/2.3.0/extensions
  /Library/Ruby/Gems/2.3.0/gems
  /Library/Ruby/Gems/2.3.0/specifications
  /usr/bin
Using addressable 2.6.0
Using bundler 2.0.1
Using colorator 1.1.0
Using concurrent-ruby 1.1.5
Using eventmachine 1.2.7
Using http_parser.rb 0.6.0
Using em-websocket 0.5.1
Using ffi 1.10.0
Using forwardable-extended 2.6.0
Using i18n 0.9.5
Using rb-fsevent 0.10.3
Using rb-inotify 0.10.0
Using sass-listen 4.0.0
Using sass 3.7.4
Using jekyll-sass-converter 1.5.2
Using ruby_dep 1.5.0
Using listen 3.1.5
Using jekyll-watch 2.2.1
Using kramdown 1.17.0
Using liquid 4.0.3
Using mercenary 0.3.6
Using pathutil 0.16.2
Using rouge 3.3.0
Using safe_yaml 1.0.5
Using jekyll 3.8.5
Using jekyll-feed 0.12.1
Using jekyll-seo-tag 2.6.0
Using minima 2.5.0
Bundle complete! 4 Gemfile dependencies, 29 gems now installed.
Use `bundle info [gemname]` to see where a bundled gem is installed.
@scottyscripts

This comment has been minimized.

Copy link

@scottyscripts scottyscripts commented Apr 20, 2019

@joshuaspy it doesn't look like your solution installs the github-pages gem at all (since you commented it out in the Gemfile)

I think we just have to wait until the github-pages gem is updated (strange it hasn't yet)... #555

BTW using jekyll 3.7.4 is all good with the newest github-pages gem

@brando90

This comment has been minimized.

Copy link

@brando90 brando90 commented Oct 28, 2019

@joshuaspy did you have this error?

$ bundle
Fetching gem metadata from https://rubygems.org/..........
Fetching gem metadata from https://rubygems.org/.
You have requested:
  jekyll ~> 3.8.5

The bundle currently has jekyll locked at 4.0.0.
Try running `bundle update jekyll`

If you are updating multiple gems in your Gemfile at once,
try passing them all to `bundle update`

https://stackoverflow.com/questions/58598084/how-does-one-downgrade-jekyll-to-work-with-github-pages

@brando90

This comment has been minimized.

Copy link

@brando90 brando90 commented Oct 29, 2019

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
6 participants
You can’t perform that action at this time.