Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Icons not showing in interactive rebase #1151

Closed
DDeis opened this issue Nov 14, 2020 · 12 comments
Closed

Icons not showing in interactive rebase #1151

DDeis opened this issue Nov 14, 2020 · 12 comments
Assignees
Labels
bug Something isn't working

Comments

@DDeis
Copy link

DDeis commented Nov 14, 2020

Hello, I'm a really enthusiastic with the new interactive rebase feature that comes with GitLens 11, though some icons are not showing, instead there is a square for branch, commit and toggle down icons as if a font was missing or something.

Capture d’écran 2020-11-14 à 22 56 24

  • GitLens Version: 11.0.0
  • Git Version: 2.24.3
  • VSCode Version: 1.51.1
  • OS Version: MacOS 11.0.1 & 10.15.7
  • Editor font family setting: Fira Code, Menlo, Monaco, 'Courier New', monospace
@DDeis DDeis added the potential-bug Seems like something isn't working label Nov 14, 2020
@kewen-feng
Copy link

Me,too

@eamodio
Copy link
Member

eamodio commented Nov 16, 2020

@lanmeidada Are you also on macOS?

@eamodio eamodio self-assigned this Nov 16, 2020
@ceecko
Copy link

ceecko commented Nov 16, 2020

I'm on Windows 10 and I can confirm this. It was even worse before restarting VSCode.
The commits were not visible at all, there was just the "Interactive Rebase" heading and labels of buttons (Start rebase and Abort) without the borders or background.

A suggestion - add a note this page is coming from gitlens so people can find an easy way to disable it (see #1153)

@DDeis
Copy link
Author

DDeis commented Nov 16, 2020

A suggestion - add a note this page is coming from gitlens so people can find an easy way to disable it (see #1153)

Indeed, I also had a hard time finding out that view was coming from GitLens 😅

@plwalsh
Copy link

plwalsh commented Nov 16, 2020

I'm also on Windows 10, and seeing squares like that in other places too, such as the gitlens settings editor:

image

Not sure if that's intentional, but it seems odd.

@eamodio
Copy link
Member

eamodio commented Nov 16, 2020

Thanks for the info. Definitely not expected. It looks like the codicons font (the built-in vscode icon set) is not being loaded correctly.

@eamodio
Copy link
Member

eamodio commented Nov 16, 2020

It looks like this issue is somewhat related to microsoft/vscode#85872

@plwalsh @DDeis @ceecko @lanmeidada Do any of you have any other missing icons?

@ceecko
Copy link

ceecko commented Nov 16, 2020

@eamodio No, all other icons are fine.

@eamodio
Copy link
Member

eamodio commented Nov 16, 2020

When you see the issue you can run the Open Webview Developer Tools command from the command palette and see if there are any errors in the console?

@plwalsh
Copy link

plwalsh commented Nov 16, 2020

I happened upon an old issue you submitted (microsoft/vscode#63967) just trying to figure out how to open that dang console 😅.. Open did nothing, Toggle opened it.

But here's what popped up in the console when I launched an interactive rebase:

image

@raphinesse
Copy link

Same issue for me in GitLens Settings & Interactive Rebase Editor (on Ubuntu)

@eamodio eamodio added this to the Soon™ milestone Nov 18, 2020
@eamodio eamodio added bug Something isn't working and removed potential-bug Seems like something isn't working labels Nov 18, 2020
@eamodio eamodio removed this from the Soon™ milestone Dec 2, 2020
@github-actions
Copy link

github-actions bot commented Jan 2, 2021

This issue has been automatically locked since there has not been any recent activity after it was closed. Please open a new issue for related bugs.

@github-actions github-actions bot locked as resolved and limited conversation to collaborators Jan 2, 2021
Sign up for free to subscribe to this conversation on GitHub. Already have an account? Sign in.
Labels
bug Something isn't working
Projects
None yet
Development

No branches or pull requests

6 participants