Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

"Copy Remote File Url" not showing line ranges #1458

Closed
shermam opened this issue Apr 12, 2021 · 5 comments
Closed

"Copy Remote File Url" not showing line ranges #1458

shermam opened this issue Apr 12, 2021 · 5 comments
Assignees
Labels
bug Something isn't working verified ✔ Verified
Milestone

Comments

@shermam
Copy link

shermam commented Apr 12, 2021

Issue Type: Bug

  • Selecte some line or lines of code in a source file tracked by git
  • Press cmd + shift + c or select the command GitLens: Copy Remote File Url

Expected

Remote Url in the clipboard contains line numbers at the end.

Actual

Remote Url does not contain line numbers at the end.

Notes:

I was able to track this change here on the file src/commands/openFileOnRemote.ts lines 92 and 93 that were introduced on PR #1344 merged a couple of weeks ago that seems to have introduced the problem.

I was able to dig through the minified version of the extension in my ~/.vscode/extensions/eamodio.gitlens-11.4.0 directory, and revert those two lines and I can confirm that it solved the problem locally for me.

I did not take the time to investigate what the original intent of that extra condition to be added was. So I don't feel comfortable writing a PR just yet. But I would love to see this functionality back since I use it everyday.

This is an awesome extension! Thanks for the awesome work!

Extension version: 11.4.0
VS Code version: Code 1.55.1 (08a217c4d27a02a5bcde898fd7981bda5b49391b, 2021-04-07T18:22:52.186Z)
OS version: Darwin x64 19.6.0

System Info
Item Value
CPUs Intel(R) Core(TM) i5-8279U CPU @ 2.40GHz (8 x 2400)
GPU Status 2d_canvas: enabled
gpu_compositing: enabled
metal: disabled_off
multiple_raster_threads: enabled_on
oop_rasterization: enabled
opengl: enabled_on
protected_video_decode: unavailable_off
rasterization: enabled
skia_renderer: disabled_off_ok
video_decode: enabled
webgl: enabled
webgl2: enabled
Load (avg) 2, 2, 3
Memory (System) 16.00GB (0.08GB free)
Process Argv --crash-reporter-id 955b19b8-7ffb-4a08-aa1f-1020d89685a2
Screen Reader no
VM 0%
A/B Experiments
vsliv368cf:30146710
vsreu685:30147344
python383:30185418
vspor879:30202332
vspor708:30202333
vspor363:30204092
vstry244:30276681
pythonvsdeb440:30248342
pythonvsded773:30248341
pythonvspyt875:30259475
pythontb:30283811
openwsldoc:30282072
vspre833:30267464
pythonptprofiler:30281270
vshan820:30276952
pythondataviewer:30285071
vscus158:30286553

@eamodio eamodio self-assigned this Apr 14, 2021
@eamodio eamodio added the bug Something isn't working label Apr 14, 2021
@eamodio eamodio added this to the Soon™ milestone Apr 14, 2021
@eamodio
Copy link
Member

eamodio commented Apr 14, 2021

Thank you for the debugging ❤️. Sorry for the inconvenience, I will get that fixed up very soon!

@eamodio
Copy link
Member

eamodio commented Apr 14, 2021

Can you please verify this fix in tomorrow's insiders edition?

You can install the insiders edition from here. Be sure to disable/uninstall the stable version of GitLens first.

@eamodio eamodio added needs-verification Request for community verification pending-release Resolved but not yet released to the stable edition labels Apr 14, 2021
@shermam
Copy link
Author

shermam commented Apr 14, 2021

Can you please verify this fix in tomorrow's insiders edition?

You can install the insiders edition from here. Be sure to disable/uninstall the stable version of GitLens first.

Yes @eamodio . Wow that was really fast! Thanks for the quick response. I will definitely verify this tomorrow and I will let you know.

@shermam
Copy link
Author

shermam commented Apr 14, 2021

I uninstalled the stable version and installed the insiders edition v2021.4.1405. And I confirm that the line ranges are back! 🎉
Thanks very much for the quick response.

@eamodio eamodio added verified ✔ Verified and removed needs-verification Request for community verification pending-release Resolved but not yet released to the stable edition labels Apr 14, 2021
@eamodio eamodio modified the milestones: Soon™, Shipped Apr 14, 2021
@github-actions
Copy link

This issue has been automatically locked since there has not been any recent activity after it was closed. Please open a new issue for related bugs.

@github-actions github-actions bot locked as resolved and limited conversation to collaborators May 15, 2021
Sign up for free to subscribe to this conversation on GitHub. Already have an account? Sign in.
Labels
bug Something isn't working verified ✔ Verified
Projects
None yet
Development

No branches or pull requests

2 participants