Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

"Don't show again" on debug log warning doesn't work #1548

Closed
roblourens opened this issue Jun 15, 2021 · 9 comments
Closed

"Don't show again" on debug log warning doesn't work #1548

roblourens opened this issue Jun 15, 2021 · 9 comments
Assignees
Labels
bug Something isn't working needs-verification Request for community verification
Milestone

Comments

@roblourens
Copy link

  • Enable debug logging
  • Use gitlens for awhile
  • Get this notification
    image
  • Click "Don't show again"
  • But I know I've seen this multiple times.

Actually maybe it's just saved per-workspace?

@roblourens roblourens added potential-bug triage Needs to be looked at labels Jun 15, 2021
@eamodio
Copy link
Member

eamodio commented Jun 16, 2021

It's saved in user settings:

"gitlens.advanced.messages": {
	"suppressDebugLoggingWarning": true
},

I'm not sure how that would fail -- maybe settings sync?

@eamodio eamodio added needs-more-info Needs further information, steps, details, etc. and removed triage Needs to be looked at labels Jun 16, 2021
@roblourens
Copy link
Author

I don't have that setting but I'll check for it next time

@roblourens
Copy link
Author

When I click "Don't show again", it doesn't add the setting

@eamodio eamodio added bug Something isn't working and removed needs-more-info Needs further information, steps, details, etc. potential-bug labels Jun 22, 2021
@eamodio eamodio self-assigned this Jun 22, 2021
@eamodio eamodio added this to the Soon™ milestone Jun 22, 2021
@eamodio eamodio added needs-verification Request for community verification pending-release Resolved but not yet released to the stable edition labels Jun 22, 2021
@eamodio
Copy link
Member

eamodio commented Jun 22, 2021

@roblourens are you aware of a settings change where we are returning a proxy object rather than a normal object? That is what causes this issue -- at some point VS Code stopped returning an object from a WorkspaceConfiguration.get call and instead returns a proxy object.

Can you please verify this fix in tomorrow's GitLens insiders edition?

You can install the GitLens insiders edition from here. Be sure to disable/uninstall the stable version of GitLens first.

@roblourens
Copy link
Author

cc @sandy081

@sandy081
Copy link

Yes the API returns proxy mainly for perf reasons - so that we do not clone the complete settings tree when we give it to the extension.

@eamodio
Copy link
Member

eamodio commented Jun 24, 2021

@sandy081 when did that change? Because that is a breaking change depending on how the object was used.

@sandy081
Copy link

3 yrs ago - microsoft/vscode#39576

@eamodio eamodio removed the pending-release Resolved but not yet released to the stable edition label Jul 13, 2021
@eamodio eamodio modified the milestones: Soon™, Shipped Jul 13, 2021
@github-actions
Copy link

This issue has been automatically locked since there has not been any recent activity after it was closed. Please open a new issue for related bugs.

@github-actions github-actions bot locked as resolved and limited conversation to collaborators Aug 13, 2021
Sign up for free to subscribe to this conversation on GitHub. Already have an account? Sign in.
Labels
bug Something isn't working needs-verification Request for community verification
Projects
None yet
Development

No branches or pull requests

3 participants