Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP

Loading…

No push, pull, clone, .. possible #20

Closed
phste opened this Issue · 5 comments

5 participants

@phste

Hi,

I updated GitLab today to 5.0 so I also installed gitlab-shell. But when I do
sudo -u git -H /home/git/gitlab-shell/bin/check
I get this error message.
check GitLab API access: /usr/local/lib/ruby/1.9.1/net/http.rb:762:in initialize': Connection refused - connect(2) (Errno::ECONNREFUSED)
from /usr/local/lib/ruby/1.9.1/net/http.rb:762:in
open'
from /usr/local/lib/ruby/1.9.1/net/http.rb:762:in block in connect'
from /usr/local/lib/ruby/1.9.1/timeout.rb:54:in
timeout'
from /usr/local/lib/ruby/1.9.1/timeout.rb:99:in timeout'
from /usr/local/lib/ruby/1.9.1/net/http.rb:762:in
connect'
from /usr/local/lib/ruby/1.9.1/net/http.rb:755:in do_start'
from /usr/local/lib/ruby/1.9.1/net/http.rb:744:in
start'
from /home/git/gitlab-shell/lib/gitlab_net.rb:42:in get'
from /home/git/gitlab-shell/lib/gitlab_net.rb:28:in
check'
from /home/git/gitlab-shell/bin/check:11:in `

'

GitLab itself is working fine

@Wattos

I just had the exact same problem.

It was a problem with the reverse proxy configuration. I had to remove the listen line:

.....
server {
listen 192.168.1.99:80 default_server; # e.g., listen 192.168.1.1:80; <-- comment this line out
....
}
....

And then it works fine

@proverbface

This error is related with Issue #3384 (gitlabhq/gitlabhq#3384).

@djgreg13

I have fixed the #3384 issue but the ssh error still here

@Razer6
Collaborator

@phste Is it still an error?

@phste

I managed to resolve it some time ago, but i don't exactly how and I forgot to close here sorry.

@phste phste closed this
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.