Permalink
Browse files

update gems in order to make it work with ruby 1.9.3

  • Loading branch information...
1 parent a7734bb commit e10fb64dd6092cc4d8f1d2feb24bbc64d5ed27de @NARKOZ NARKOZ committed Nov 16, 2011
Showing with 90 additions and 111 deletions.
  1. +7 −9 Gemfile
  2. +82 −102 Gemfile.lock
  3. +1 −0 spec/spec_helper.rb
View
16 Gemfile
@@ -1,9 +1,9 @@
source 'http://rubygems.org'
-gem 'rails', '3.1.0'
+gem 'rails', '3.1.1'
gem 'sqlite3'
-gem 'devise', "1.4.7"
+gem 'devise', "1.5.0"
gem 'stamp'
gem 'kaminari'
gem 'haml-rails'
@@ -13,25 +13,24 @@ gem "carrierwave"
gem 'six'
gem 'therubyracer'
gem 'faker'
-gem 'seed-fu', :git => 'git://github.com/mbleigh/seed-fu.git'
+gem 'seed-fu', '~> 2.1.0'
gem "inifile"
gem "pygments.rb", "0.2.3"
gem "thin"
gem "git"
gem "acts_as_list"
gem 'rdiscount'
-
-gem 'acts-as-taggable-on', '~>2.1.0'
+gem 'acts-as-taggable-on', '~> 2.1.0'
group :assets do
- gem 'sass-rails', " ~> 3.1.0"
+ gem 'sass-rails', "~> 3.1.0"
gem 'coffee-rails', "~> 3.1.0"
gem 'uglifier'
end
group :development do
gem 'letter_opener'
- gem 'rails-footnotes', '>= 3.7.5.rc4'
+ gem 'rails-footnotes', '~> 3.7.5'
gem 'annotate', :git => 'git://github.com/ctran/annotate_models.git'
end
@@ -40,13 +39,12 @@ group :development, :test do
gem 'capybara'
gem 'autotest'
gem 'autotest-rails'
- gem 'ruby-debug19', :require => 'ruby-debug'
+ # gem 'ruby-debug19', :require => 'ruby-debug'
gem 'awesome_print'
gem 'database_cleaner'
gem 'launchy'
end
-
group :test do
gem 'turn', :require => false
gem 'simplecov', :require => false
View
@@ -1,6 +1,6 @@
GIT
remote: git://github.com/ctran/annotate_models.git
- revision: cfeec96c9ca0fa5035b10be3d73e798cc4fc52f7
+ revision: fb73329243056a6d9a64878e5c543aba9b6417de
specs:
annotate (2.4.1.beta1)
@@ -13,53 +13,43 @@ GIT
mime-types (~> 1.15)
posix-spawn (~> 0.3.6)
-GIT
- remote: git://github.com/mbleigh/seed-fu.git
- revision: 77be06852b18fb01e272ab763ddb292da575586c
- specs:
- seed-fu (2.1.0)
- activerecord (~> 3.1.0)
- activesupport (~> 3.1.0)
-
GEM
remote: http://rubygems.org/
specs:
ZenTest (4.5.0)
- actionmailer (3.1.0)
- actionpack (= 3.1.0)
+ actionmailer (3.1.1)
+ actionpack (= 3.1.1)
mail (~> 2.3.0)
- actionpack (3.1.0)
- activemodel (= 3.1.0)
- activesupport (= 3.1.0)
+ actionpack (3.1.1)
+ activemodel (= 3.1.1)
+ activesupport (= 3.1.1)
builder (~> 3.0.0)
erubis (~> 2.7.0)
i18n (~> 0.6)
rack (~> 1.3.2)
- rack-cache (~> 1.0.3)
+ rack-cache (~> 1.1)
rack-mount (~> 0.8.2)
rack-test (~> 0.6.1)
- sprockets (~> 2.0.0)
- activemodel (3.1.0)
- activesupport (= 3.1.0)
- bcrypt-ruby (~> 3.0.0)
+ sprockets (~> 2.0.2)
+ activemodel (3.1.1)
+ activesupport (= 3.1.1)
builder (~> 3.0.0)
i18n (~> 0.6)
- activerecord (3.1.0)
- activemodel (= 3.1.0)
- activesupport (= 3.1.0)
+ activerecord (3.1.1)
+ activemodel (= 3.1.1)
+ activesupport (= 3.1.1)
arel (~> 2.2.1)
tzinfo (~> 0.3.29)
- activeresource (3.1.0)
- activemodel (= 3.1.0)
- activesupport (= 3.1.0)
- activesupport (3.1.0)
+ activeresource (3.1.1)
+ activemodel (= 3.1.1)
+ activesupport (= 3.1.1)
+ activesupport (3.1.1)
multi_json (~> 1.0)
acts-as-taggable-on (2.1.1)
rails
acts_as_list (0.1.4)
addressable (2.2.6)
- ansi (1.3.0)
- archive-tar-minitar (0.5.2)
+ ansi (1.4.1)
arel (2.2.1)
autotest (4.4.6)
ZenTest (>= 4.4.1)
@@ -69,14 +59,14 @@ GEM
bcrypt-ruby (3.0.1)
blankslate (2.1.2.4)
builder (3.0.0)
- capybara (1.0.1)
+ capybara (1.1.2)
mime-types (>= 1.16)
nokogiri (>= 1.3.3)
rack (>= 1.0.0)
rack-test (>= 0.5.4)
selenium-webdriver (~> 2.0)
xpath (~> 0.1.4)
- carrierwave (0.5.7)
+ carrierwave (0.5.8)
activesupport (~> 3.0)
childprocess (0.2.2)
ffi (~> 1.0.6)
@@ -86,22 +76,21 @@ GEM
coffee-script (2.2.0)
coffee-script-source
execjs
- coffee-script-source (1.1.2)
- columnize (0.3.4)
+ coffee-script-source (1.1.3)
daemons (1.1.4)
- database_cleaner (0.6.7)
- devise (1.4.7)
+ database_cleaner (0.7.0)
+ devise (1.5.0)
bcrypt-ruby (~> 3.0)
orm_adapter (~> 0.0.3)
- warden (~> 1.0.3)
+ warden (~> 1.1)
diff-lcs (1.1.3)
erubis (2.7.0)
eventmachine (0.12.10)
- execjs (1.2.6)
+ execjs (1.2.9)
multi_json (~> 1.0)
- faker (0.9.5)
+ faker (1.0.1)
i18n (~> 0.4)
- ffi (1.0.9)
+ ffi (1.0.11)
git (1.2.5)
haml (3.1.3)
haml-rails (0.3.4)
@@ -112,119 +101,111 @@ GEM
hike (1.2.1)
i18n (0.6.0)
inifile (0.4.1)
- jquery-rails (1.0.14)
+ jquery-rails (1.0.17)
railties (~> 3.0)
thor (~> 0.14)
- json_pure (1.5.4)
- spruz (~> 0.2.8)
+ json (1.6.1)
+ json_pure (1.6.1)
kaminari (0.12.4)
rails (>= 3.0.0)
launchy (2.0.5)
addressable (~> 2.2.6)
letter_opener (0.0.2)
launchy
- libv8 (3.3.10.2)
- linecache19 (0.5.12)
- ruby_core_source (>= 0.1.4)
+ libv8 (3.3.10.4)
mail (2.3.0)
i18n (>= 0.4.0)
mime-types (~> 1.16)
treetop (~> 1.4.8)
- mime-types (1.16)
+ mime-types (1.17.2)
multi_json (1.0.3)
nokogiri (1.5.0)
orm_adapter (0.0.5)
- polyglot (0.3.2)
+ polyglot (0.3.3)
posix-spawn (0.3.6)
pygments.rb (0.2.3)
rubypython (>= 0.5.1)
- rack (1.3.2)
- rack-cache (1.0.3)
+ rack (1.3.5)
+ rack-cache (1.1)
rack (>= 0.4)
rack-mount (0.8.3)
rack (>= 1.0.0)
rack-ssl (1.3.2)
rack
rack-test (0.6.1)
rack (>= 1.0)
- rails (3.1.0)
- actionmailer (= 3.1.0)
- actionpack (= 3.1.0)
- activerecord (= 3.1.0)
- activeresource (= 3.1.0)
- activesupport (= 3.1.0)
+ rails (3.1.1)
+ actionmailer (= 3.1.1)
+ actionpack (= 3.1.1)
+ activerecord (= 3.1.1)
+ activeresource (= 3.1.1)
+ activesupport (= 3.1.1)
bundler (~> 1.0)
- railties (= 3.1.0)
- rails-footnotes (3.7.5.rc4)
+ railties (= 3.1.1)
+ rails-footnotes (3.7.5)
rails (>= 3.0.0)
- railties (3.1.0)
- actionpack (= 3.1.0)
- activesupport (= 3.1.0)
+ railties (3.1.1)
+ actionpack (= 3.1.1)
+ activesupport (= 3.1.1)
rack-ssl (~> 1.3.2)
rake (>= 0.8.7)
rdoc (~> 3.4)
thor (~> 0.14.6)
- rake (0.9.2)
+ rake (0.9.2.2)
rdiscount (1.6.8)
- rdoc (3.9.4)
- rspec (2.6.0)
- rspec-core (~> 2.6.0)
- rspec-expectations (~> 2.6.0)
- rspec-mocks (~> 2.6.0)
- rspec-core (2.6.4)
- rspec-expectations (2.6.0)
+ rdoc (3.11)
+ json (~> 1.4)
+ rspec (2.7.0)
+ rspec-core (~> 2.7.0)
+ rspec-expectations (~> 2.7.0)
+ rspec-mocks (~> 2.7.0)
+ rspec-core (2.7.1)
+ rspec-expectations (2.7.0)
diff-lcs (~> 1.1.2)
- rspec-mocks (2.6.0)
- rspec-rails (2.6.1)
+ rspec-mocks (2.7.0)
+ rspec-rails (2.7.0)
actionpack (~> 3.0)
activesupport (~> 3.0)
railties (~> 3.0)
- rspec (~> 2.6.0)
- ruby-debug-base19 (0.11.25)
- columnize (>= 0.3.1)
- linecache19 (>= 0.5.11)
- ruby_core_source (>= 0.1.4)
- ruby-debug19 (0.11.6)
- columnize (>= 0.3.1)
- linecache19 (>= 0.5.11)
- ruby-debug-base19 (>= 0.11.19)
- ruby_core_source (0.1.5)
- archive-tar-minitar (>= 0.5.2)
- rubypython (0.5.1)
+ rspec (~> 2.7.0)
+ rubypython (0.5.3)
blankslate (>= 2.1.2.3)
ffi (~> 1.0.7)
rubyzip (0.9.4)
- sass (3.1.7)
- sass-rails (3.1.1)
+ sass (3.1.10)
+ sass-rails (3.1.4)
actionpack (~> 3.1.0)
railties (~> 3.1.0)
sass (>= 3.1.4)
+ sprockets (~> 2.0.0)
tilt (~> 1.3.2)
- selenium-webdriver (2.5.0)
+ seed-fu (2.1.0)
+ activerecord (~> 3.1.0)
+ activesupport (~> 3.1.0)
+ selenium-webdriver (2.12.2)
childprocess (>= 0.2.1)
- ffi (>= 1.0.7)
+ ffi (~> 1.0.9)
json_pure
rubyzip
shoulda (3.0.0.beta2)
shoulda-context (~> 1.0.0.beta1)
shoulda-matchers (~> 1.0.0.beta1)
- shoulda-context (1.0.0.beta1)
- shoulda-matchers (1.0.0.beta3)
- simplecov (0.5.3)
+ shoulda-context (1.0.0)
+ shoulda-matchers (1.0.0)
+ simplecov (0.5.4)
multi_json (~> 1.0.3)
simplecov-html (~> 0.5.3)
simplecov-html (0.5.3)
six (0.2.0)
- sprockets (2.0.0)
+ sprockets (2.0.3)
hike (~> 1.2)
rack (~> 1.0)
tilt (~> 1.1, != 1.3.0)
- spruz (0.2.13)
sqlite3 (1.3.4)
stamp (0.1.6)
- therubyracer (0.9.4)
+ therubyracer (0.9.9)
libv8 (~> 3.3.10)
- thin (1.2.11)
+ thin (1.3.1)
daemons (>= 1.0.9)
eventmachine (>= 0.12.6)
rack (>= 1.0.0)
@@ -233,13 +214,13 @@ GEM
treetop (1.4.10)
polyglot
polyglot (>= 0.3.1)
- turn (0.8.2)
- ansi (>= 1.2.2)
- tzinfo (0.3.29)
- uglifier (1.0.3)
+ turn (0.8.3)
+ ansi
+ tzinfo (0.3.31)
+ uglifier (1.1.0)
execjs (>= 0.3.0)
multi_json (>= 1.0.2)
- warden (1.0.5)
+ warden (1.1.0)
rack (>= 1.0)
xpath (0.1.4)
nokogiri (~> 1.3)
@@ -258,7 +239,7 @@ DEPENDENCIES
carrierwave
coffee-rails (~> 3.1.0)
database_cleaner
- devise (= 1.4.7)
+ devise (= 1.5.0)
faker
git
grit!
@@ -269,13 +250,12 @@ DEPENDENCIES
launchy
letter_opener
pygments.rb (= 0.2.3)
- rails (= 3.1.0)
- rails-footnotes (>= 3.7.5.rc4)
+ rails (= 3.1.1)
+ rails-footnotes (~> 3.7.5)
rdiscount
rspec-rails
- ruby-debug19
sass-rails (~> 3.1.0)
- seed-fu!
+ seed-fu (~> 2.1.0)
shoulda (~> 3.0.0.beta2)
simplecov
six
Oops, something went wrong.

0 comments on commit e10fb64

Please sign in to comment.