Files root breadcrumbs link removes the files view #1885

Closed
mktums opened this Issue Oct 31, 2012 · 4 comments

Comments

Projects
None yet
5 participants
@mktums
Contributor

mktums commented Oct 31, 2012

When on project "Files" page you clicking at "root" link (with project name within it) UI brokes with no output in file listing frame. Re-clicking on it doesn't work too.

Before clicking ("root link" in this case is "parsers"):
UI before clicking on root breadcrumb link

After clicking:
UI after clicking on root breadcrumb link

@rspeicher

This comment has been minimized.

Show comment Hide comment
@rspeicher

rspeicher Nov 2, 2012

Owner

I was only able to reproduce this once in the course of my fixing #1731 - please try the latest master and see if that fixes things.

Owner

rspeicher commented Nov 2, 2012

I was only able to reproduce this once in the course of my fixing #1731 - please try the latest master and see if that fixes things.

@riyad

This comment has been minimized.

Show comment Hide comment
@riyad

riyad Nov 6, 2012

Contributor

I've done some testing this is not specific to the root/project link. This actually happens every time you click the (breadcrumbs) link for the page you are currently on.
@tsigo Any idea why this might be the case?

Contributor

riyad commented Nov 6, 2012

I've done some testing this is not specific to the root/project link. This actually happens every time you click the (breadcrumbs) link for the page you are currently on.
@tsigo Any idea why this might be the case?

@rspeicher

This comment has been minimized.

Show comment Hide comment
@rspeicher

rspeicher Nov 6, 2012

Owner

Best guess, clicking the link is triggering the slide/hide animation, but since the actual state isn't changing (the url is the same), the "new" page isn't fetched and put in place of the part that was just hidden. Maybe we should move the slide/hide to the statechange callback.

Owner

rspeicher commented Nov 6, 2012

Best guess, clicking the link is triggering the slide/hide animation, but since the actual state isn't changing (the url is the same), the "new" page isn't fetched and put in place of the part that was just hidden. Maybe we should move the slide/hide to the statechange callback.

@mikkyhouse mikkyhouse closed this Feb 25, 2013

@jpscharf

This comment has been minimized.

Show comment Hide comment
@jpscharf

jpscharf Mar 25, 2013

This happening to me in v5.0

This happening to me in v5.0

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment