Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

Already on GitHub? Sign in to your account

Install procedure doesn't work #559

Closed
devsun opened this Issue Mar 16, 2012 · 5 comments

Comments

Projects
None yet
4 participants

devsun commented Mar 16, 2012

From here - https://github.com/gitlabhq/gitlabhq/blob/master/doc/installation.md
Running on brand new clean version of Ubuntu 11.10.

Works until this line:
sudo -u gitlab unicorn_rails -c config/unicorn.rb -E production -D

Probably because we haven't installed unicorn yet. Need to add this:
sudo gem install unicorn

But even with that, it still doesn't work. It gives this error:
master failed to start, check stderr log for details

What is the fix?

Contributor

rtripault commented Mar 16, 2012

Tested this procedure on Debian Squeeze and had the same trouble. You can use -d parameter to display the errors

sudo -u gitlab unicorn_rails -c config/unicorn.rb -E production -D -d

Contributor

vsizov commented Mar 16, 2012

we use bundler, the unicorn do not need separate installing

Contributor

vsizov commented Mar 16, 2012

sudo -u gitlab bundle exec rails s

what do you see now?

Contributor

dubcanada commented Mar 16, 2012

If you use bundle exec it seems to do things

sudo -u gitlab bundle exec unicorn_rails -c config/unicorn.rb -E production -D

But I'm not sure if it is actually doing what it should be doing.

Contributor

vsizov commented Mar 16, 2012

f4646f9
fixed

@vsizov vsizov closed this Mar 16, 2012

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment