Switch branches/tags
Find file History
Permalink
..
Failed to load latest commit information.
10.0-to-10.1.md Exclude comments from specific docs Nov 1, 2017
10.1-to-10.2.md Update installation and upgrade guides to use Ruby 2.3.6 Dec 20, 2017
10.2-to-10.3.md fix documentation about node version Jan 25, 2018
10.3-to-10.4.md fix documentation about node version Jan 25, 2018
10.4-to-10.5.md Create update guide for 10.5 Feb 8, 2018
10.5-to-10.6.md Recommend a `--prune` while `git fetch`ing Mar 29, 2018
10.6-to-10.7.md Update 10.6-to-10.7.md Jul 13, 2018
10.7-to-10.8.md Removing not necessarily indentations in update Ruby code block Aug 23, 2018
10.8-to-11.0.md Use the branch instead of the tag to install Jun 26, 2018
11.0-to-11.1.md Document update for GitLab Pages users. Jul 10, 2018
11.1-to-11.2.md Create update guide from 11.1 to 11.2 Jul 31, 2018
2.6-to-3.0.md Exclude comments from specific docs Nov 1, 2017
2.9-to-3.0.md Exclude comments from specific docs Nov 1, 2017
3.0-to-3.1.md Exclude comments from specific docs Nov 1, 2017
3.1-to-4.0.md Exclude comments from specific docs Nov 1, 2017
4.0-to-4.1.md Exclude comments from specific docs Nov 1, 2017
4.1-to-4.2.md Exclude comments from specific docs Nov 1, 2017
4.2-to-5.0.md Exclude comments from specific docs Nov 1, 2017
5.0-to-5.1.md Exclude comments from specific docs Nov 1, 2017
5.1-to-5.2.md Exclude comments from specific docs Nov 1, 2017
5.1-to-5.4.md Exclude comments from specific docs Nov 1, 2017
5.1-to-6.0.md Exclude comments from specific docs Nov 1, 2017
5.2-to-5.3.md Exclude comments from specific docs Nov 1, 2017
5.3-to-5.4.md Exclude comments from specific docs Nov 1, 2017
5.4-to-6.0.md Exclude comments from specific docs Nov 1, 2017
6.0-to-6.1.md Exclude comments from specific docs Nov 1, 2017
6.1-to-6.2.md Exclude comments from specific docs Nov 1, 2017
6.2-to-6.3.md Exclude comments from specific docs Nov 1, 2017
6.3-to-6.4.md Exclude comments from specific docs Nov 1, 2017
6.4-to-6.5.md Exclude comments from specific docs Nov 1, 2017
6.5-to-6.6.md Exclude comments from specific docs Nov 1, 2017
6.6-to-6.7.md Exclude comments from specific docs Nov 1, 2017
6.7-to-6.8.md Exclude comments from specific docs Nov 1, 2017
6.8-to-6.9.md Exclude comments from specific docs Nov 1, 2017
6.9-to-7.0.md Exclude comments from specific docs Nov 1, 2017
6.x-or-7.x-to-7.14.md Exclude comments from specific docs Nov 1, 2017
7.0-to-7.1.md Exclude comments from specific docs Nov 1, 2017
7.1-to-7.2.md Exclude comments from specific docs Nov 1, 2017
7.10-to-7.11.md Exclude comments from specific docs Nov 1, 2017
7.11-to-7.12.md Exclude comments from specific docs Nov 1, 2017
7.12-to-7.13.md Exclude comments from specific docs Nov 1, 2017
7.13-to-7.14.md Exclude comments from specific docs Nov 1, 2017
7.14-to-8.0.md Exclude comments from specific docs Nov 1, 2017
7.2-to-7.3.md Exclude comments from specific docs Nov 1, 2017
7.3-to-7.4.md Exclude comments from specific docs Nov 1, 2017
7.4-to-7.5.md Exclude comments from specific docs Nov 1, 2017
7.5-to-7.6.md Exclude comments from specific docs Nov 1, 2017
7.6-to-7.7.md Exclude comments from specific docs Nov 1, 2017
7.7-to-7.8.md Exclude comments from specific docs Nov 1, 2017
7.8-to-7.9.md Exclude comments from specific docs Nov 1, 2017
7.9-to-7.10.md Exclude comments from specific docs Nov 1, 2017
8.0-to-8.1.md Exclude comments from specific docs Nov 1, 2017
8.1-to-8.2.md Exclude comments from specific docs Nov 1, 2017
8.10-to-8.11.md Exclude comments from specific docs Nov 1, 2017
8.11-to-8.12.md Exclude comments from specific docs Nov 1, 2017
8.12-to-8.13.md Exclude comments from specific docs Nov 1, 2017
8.13-to-8.14.md Exclude comments from specific docs Nov 1, 2017
8.14-to-8.15.md Exclude comments from specific docs Nov 1, 2017
8.15-to-8.16.md Exclude comments from specific docs Nov 1, 2017
8.16-to-8.17.md Exclude comments from specific docs Nov 1, 2017
8.17-to-9.0.md Exclude comments from specific docs Nov 1, 2017
8.2-to-8.3.md Exclude comments from specific docs Nov 1, 2017
8.3-to-8.4.md Exclude comments from specific docs Nov 1, 2017
8.4-to-8.5.md Exclude comments from specific docs Nov 1, 2017
8.5-to-8.6.md Exclude comments from specific docs Nov 1, 2017
8.6-to-8.7.md Exclude comments from specific docs Nov 1, 2017
8.7-to-8.8.md Exclude comments from specific docs Nov 1, 2017
8.8-to-8.9.md Exclude comments from specific docs Nov 1, 2017
8.9-to-8.10.md Exclude comments from specific docs Nov 1, 2017
9.0-to-9.1.md Exclude comments from specific docs Nov 1, 2017
9.1-to-9.2.md Exclude comments from specific docs Nov 1, 2017
9.2-to-9.3.md Exclude comments from specific docs Nov 1, 2017
9.3-to-9.4.md Exclude comments from specific docs Nov 1, 2017
9.4-to-9.5.md Exclude comments from specific docs Nov 1, 2017
9.5-to-10.0.md Exclude comments from specific docs Nov 1, 2017
README.md Update the update guides for background migrations Aug 4, 2017
mysql_to_postgresql.md Update mysql_to_postgresql.md Jul 20, 2018
patch_versions.md Added gitlab-pages update instructions. Aug 1, 2018
restore_after_failure.md Reload the schema before restoring a database backup Mar 22, 2016
upgrader.md Exclude comments from specific docs Nov 1, 2017
upgrading_postgresql_using_slony.md Added guide for upgrading Postgres using Slony Nov 1, 2016

README.md

Updating GitLab

Depending on the installation method and your GitLab version, there are multiple update guides.

There are currently 3 official ways to install GitLab:

  • Omnibus packages
  • Source installation
  • Docker installation

Based on your installation, choose a section below that fits your needs.

Omnibus Packages

Installation from source

Installation using Docker

GitLab provides official Docker images for both Community and Enterprise editions. They are based on the Omnibus package and instructions on how to update them are in a separate document.

Upgrading without downtime

Starting with GitLab 9.1.0 it's possible to upgrade to a newer major, minor, or patch version of GitLab without having to take your GitLab instance offline. However, for this to work there are the following requirements:

  1. You can only upgrade 1 minor release at a time. So from 9.1 to 9.2, not to 9.3.
  2. You have to use post-deployment migrations.
  3. You are using PostgreSQL. If you are using MySQL please look at the release post to see if downtime is required.

Most of the time you can safely upgrade from a patch release to the next minor release if the patch release is not the latest. For example, upgrading from 9.1.1 to 9.2.0 should be safe even if 9.1.2 has been released. We do recommend you check the release posts of any releases between your current and target version just in case they include any migrations that may require you to upgrade 1 release at a time.

Some releases may also include so called "background migrations". These migrations are performed in the background by Sidekiq and are often used for migrating data. Background migrations are only added in the monthly releases.

Certain major/minor releases may require a set of background migrations to be finished. To guarantee this such a release will process any remaining jobs before continuing the upgrading procedure. While this won't require downtime (if the above conditions are met) we recommend users to keep at least 1 week between upgrading major/minor releases, allowing the background migrations to finish. The time necessary to complete these migrations can be reduced by increasing the number of Sidekiq workers that can process jobs in the background_migration queue.

As a rule of thumb, any database smaller than 10 GB won't take too much time to upgrade; perhaps an hour at most per minor release. Larger databases however may require more time, but this is highly dependent on the size of the database and the migrations that are being performed.

Examples

To help explain this, let's look at some examples.

Example 1: You are running a large GitLab installation using version 9.4.2, which is the latest patch release of 9.4. When GitLab 9.5.0 is released this installation can be safely upgraded to 9.5.0 without requiring downtime if the requirements mentioned above are met. You can also skip 9.5.0 and upgrade to 9.5.1 once it's released, but you can not upgrade straight to 9.6.0; you have to first upgrade to a 9.5.x release.

Example 2: You are running a large GitLab installation using version 9.4.2, which is the latest patch release of 9.4. GitLab 9.5 includes some background migrations, and 10.0 will require these to be completed (processing any remaining jobs for you). Skipping 9.5 is not possible without downtime, and due to the background migrations would require potentially hours of downtime depending on how long it takes for the background migrations to complete. To work around this you will have to upgrade to 9.5.x first, then wait at least a week before upgrading to 10.0.

Example 3: You use MySQL as the database for GitLab. Any upgrade to a new major/minor release will require downtime. If a release includes any background migrations this could potentially lead to hours of downtime, depending on the size of your database. To work around this you will have to use PostgreSQL and meet the other online upgrade requirements mentioned above.

Upgrading between editions

GitLab comes in two flavors: Community Edition which is MIT licensed, and Enterprise Edition which builds on top of the Community Edition and includes extra features mainly aimed at organizations with more than 100 users.

Below you can find some guides to help you change editions easily.

Community to Enterprise Edition

Note: The following guides are for subscribers of the Enterprise Edition only.

If you wish to upgrade your GitLab installation from Community to Enterprise Edition, follow the guides below based on the installation method:

  • Source CE to EE update guides - Find your version, and follow the -ce-to-ee.md guide. The steps are very similar to a version upgrade: stop the server, get the code, update config files for the new functionality, install libraries and do migrations, update the init script, start the application and check its status.
  • Omnibus CE to EE - Follow this guide to update your Omnibus GitLab Community Edition to the Enterprise Edition.

Enterprise to Community Edition

If you need to downgrade your Enterprise Edition installation back to Community Edition, you can follow this guide to make the process as smooth as possible.

Miscellaneous