Skip to content
Browse files

setup.py: fixed incorrect handling of toplevel package path - I must …

…have been very confused when setting it up that way
  • Loading branch information...
1 parent 031271e commit 5eb7fd3f0dd99dc6c49da6fd7e78a392c4ef1b33 @Byron Byron committed Jan 17, 2011
Showing with 4 additions and 5 deletions.
  1. +4 −5 setup.py
View
9 setup.py
@@ -40,7 +40,7 @@ def make_release_tree (self, base_dir, files):
def _stamp_version(filename):
- found, out = False, []
+ found, out = False, list()
try:
f = open(filename, 'r')
except (IOError, OSError):
@@ -61,18 +61,17 @@ def _stamp_version(filename):
else:
print >> sys.stderr, "WARNING: Couldn't find version line in file %s" % filename
-
setup(name = "GitPython",
cmdclass={'build_py': build_py, 'sdist': sdist},
version = VERSION,
description = "Python Git Library",
author = "Sebastian Thiel, Michael Trier",
author_email = "byronimo@gmail.com, mtrier@gmail.com",
url = "http://gitorious.org/projects/git-python/",
- packages = ['git.'+p for p in find_packages('.')],
- py_modules = ['git.'+f[:-3] for f in os.listdir('.') if f.endswith('.py')],
+ packages = find_packages('.'),
+ py_modules = ['git.'+f[:-3] for f in os.listdir('./git') if f.endswith('.py')],
package_data = {'git.test' : ['fixtures/*']},
- package_dir = {'git':''},
+ package_dir = {'git':'git'},
license = "BSD License",
requires=('gitdb (>=0.5.1)',),
install_requires='gitdb >= 0.5.1',

0 comments on commit 5eb7fd3

Please sign in to comment.
Something went wrong with that request. Please try again.