Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
branch: master
Fetching contributors…

Cannot retrieve contributors at this time

executable file 43 lines (37 sloc) 1.964 kb
#!/usr/bin/env ruby -rubygems
# -*- encoding: utf-8 -*-
Gem::Specification.new do |gem|
gem.version = File.read('VERSION').chomp
gem.date = File.mtime('VERSION').strftime('%Y-%m-%d')
gem.name = "json-ld"
gem.homepage = "http://github.com/gkellogg/json-ld"
gem.license = 'Public Domain' if gem.respond_to?(:license=)
gem.summary = "JSON-LD reader/writer for Ruby."
gem.description = "JSON::LD parses and serializes JSON-LD into RDF and implements expansion, compaction and framing API interfaces."
gem.rubyforge_project = 'json-ld'
gem.authors = ['Gregg Kellogg']
gem.email = 'public-linked-json@w3.org'
gem.platform = Gem::Platform::RUBY
gem.files = %w(AUTHORS README.md UNLICENSE VERSION) + Dir.glob('lib/**/*.rb')
gem.bindir = %q(bin)
gem.executables = %w(jsonld)
gem.default_executable = gem.executables.first
gem.require_paths = %w(lib)
gem.extensions = %w()
gem.test_files = Dir.glob('spec/**/*.rb') + Dir.glob('spec/test-files/*')
gem.has_rdoc = false
gem.required_ruby_version = '>= 1.9.3'
gem.requirements = []
gem.add_runtime_dependency 'rdf', '>= 1.0'
gem.add_runtime_dependency 'json', '>= 1.7.5'
gem.add_development_dependency 'equivalent-xml' , '>= 0.2.8'
gem.add_development_dependency 'open-uri-cached', '>= 0.0.5'
gem.add_development_dependency 'yard' , '>= 0.8.3'
gem.add_development_dependency 'rspec', '>= 2.12.0'
gem.add_development_dependency 'rdf-spec', '>= 1.0'
gem.add_development_dependency 'rdf-turtle'
gem.add_development_dependency 'rdf-trig'
gem.add_development_dependency 'rdf-isomorphic'
gem.add_development_dependency 'rdf-xsd'
gem.post_install_message = nil
end
Jump to Line
Something went wrong with that request. Please try again.