cannot load such file -- xml/xslt #39

Closed
Shamaoke opened this Issue Feb 6, 2012 · 2 comments

Projects

None yet

2 participants

@Shamaoke
Shamaoke commented Feb 6, 2012

Hi.

When I try to run git2gv inside a git repository I get the following output:

GraphViz#add_node is deprecated, please use GraphViz#add_nodes
GraphViz#add_node is deprecated, please use GraphViz#add_nodes
GraphViz#add_node is deprecated, please use GraphViz#add_nodes
GraphViz#add_node is deprecated, please use GraphViz#add_nodes
fatal: ambiguous argument 'master': unknown revision or path not in the working tree.
Use '--' to separate paths from revisions
GraphViz#add_edge is deprecated, please use GraphViz#add_edges
GraphViz#add_edge is deprecated, please use GraphViz#add_edges
GraphViz#add_edge is deprecated, please use GraphViz#add_edges
/home/<username>/.rvm/rubies/ruby-1.9.3-p0/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:36:in `require': cannot load such file -- xml/xslt (LoadError)
        from /home/<username>/.rvm/rubies/ruby-1.9.3-p0/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:36:in `require'
        from /home/<username>/.rvm/gems/ruby-1.9.3-p0@global/gems/ruby-graphviz-1.0.4/lib/graphviz/nothugly.rb:11:in `<top (required)>'
        from /home/<username>/.rvm/rubies/ruby-1.9.3-p0/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:36:in `require'
        from /home/<username>/.rvm/rubies/ruby-1.9.3-p0/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:36:in `require'
        from /home/<username>/.rvm/gems/ruby-1.9.3-p0@global/gems/ruby-graphviz-1.0.4/lib/graphviz.rb:550:in `block in output'
        from /home/<username>/.rvm/gems/ruby-1.9.3-p0@global/gems/ruby-graphviz-1.0.4/lib/graphviz.rb:504:in `each'
        from /home/<username>/.rvm/gems/ruby-1.9.3-p0@global/gems/ruby-graphviz-1.0.4/lib/graphviz.rb:504:in `output'
        from /home/<username>/.rvm/gems/ruby-1.9.3-p0@global/gems/ruby-graphviz-1.0.4/bin/git2gv:53:in `run'
        from /home/<username>/.rvm/gems/ruby-1.9.3-p0@global/gems/ruby-graphviz-1.0.4/bin/git2gv:168:in `<top (required)>'
        from /home/<username>/.rvm/gems/ruby-1.9.3-p0@global/bin/git2gv:19:in `load'
        from /home/<username>/.rvm/gems/ruby-1.9.3-p0@global/bin/git2gv:19:in `<main>'

What is the reason of this issue? How can I force ruby-graphviz to work correctly?

Thanks.

Debian GNU/Linux 6.0.3;

Ruby 1.9.3-p0;

Graphviz 2.26.3;

Ruby-graphviz 1.0.4.

@glejeune glejeune added a commit that referenced this issue Feb 6, 2012
@glejeune Issue #39 852ee11
@glejeune
Owner
glejeune commented Feb 6, 2012

I made a correction. You can upgrade to 1.0.5. Thanks

@glejeune glejeune closed this Feb 6, 2012
@Shamaoke
Shamaoke commented Feb 7, 2012

Very thanks, glejeune. You made a great work. Keep going.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment