Fully featured framework for community-driven rails applications
Ruby
Switch branches/tags
Nothing to show
Fetching latest commit…
Cannot retrieve the latest commit at this time.
Permalink
Failed to load latest commit information.
app
assets
config
db/migrate
lib
test
MIT-LICENSE
README
Rakefile
init.rb
install.rb
uninstall.rb

README

Trainyard v0.7
==============

Framework to build powerful community-driven rails applications.

This plugin requires these other plugins to be installed:
  * engines
  * authlogic
  * acts_as_list
  * make_resourceful
  * fckeditor
  * http_accept_language
  * paperclip
  * active_enumeration
  * indexer
  * searchable_record
  * will_paginate
  
Optional plugins are:
  * recaptcha
  * geographer
  * geokit-rails (with geokit-gem)

The standard initialization of an engine plugin is also required.
In your application's routes.rb add this line:

  map.from_plugin :trainyard

Run this from the command line (necessary only once after all engine plugins are installed):

  script/generate plugin_migration && rake db:migrate


Note that this plugin is currently in pre-production version, so it is in development, and may need to be
reinstalled when it reaches it's first production release.


Copyright (c) 2009 Glenn Powell, released under the MIT license