asyncio + PyQt5/PySide2
Switch branches/tags
Nothing to show
Clone or download
Fetching latest commit…
Cannot retrieve the latest commit at this time.

README.rst

asyncqt - asyncio + PyQt5/PySide2

Build Status Build Status Coverage PyPI Version

asyncqt is an implementation of the PEP 3156 event-loop with Qt. This package is a fork of quamash focusing on modern Python versions, with some extra utilities, examples and simplified CI.

Requirements

asyncqt requires Python >= 3.5 and PyQt5 or PySide2. The Qt API can be explicitly set by using the QT_API environment variable.

Installation

pip install asyncqt

Examples

You can find usage examples in the examples folder.