Permalink
Browse files

Merge pull request #5 from tomjanssens/master

Registering gem.
  • Loading branch information...
2 parents e091aab + 633440e commit c8355eb523141db11299975e8c8750aa81f589c1 @gmurphey committed Apr 4, 2015
Showing with 205 additions and 0 deletions.
  1. +14 −0 Gemfile
  2. +80 −0 Gemfile.lock
  3. +51 −0 Rakefile
  4. +1 −0 VERSION
  5. +59 −0 jekyll-prism-plugin.gemspec
  6. 0 prism.rb → lib/jekyll-prism-plugin.rb
View
14 Gemfile
@@ -0,0 +1,14 @@
+source "http://rubygems.org"
+# Add dependencies required to use your gem here.
+# Example:
+# gem "activesupport", ">= 2.3.5"
+
+# Add dependencies to develop your gem here.
+# Include everything needed to run rake, tests, features, etc.
+group :development do
+ gem "shoulda", ">= 0"
+ gem "rdoc", "~> 3.12"
+ gem "bundler", "~> 1.0"
+ gem "jeweler", "~> 2.0.1"
+ gem "simplecov", ">= 0"
+end
View
@@ -0,0 +1,80 @@
+GEM
+ remote: http://rubygems.org/
+ specs:
+ activesupport (4.1.4)
+ i18n (~> 0.6, >= 0.6.9)
+ json (~> 1.7, >= 1.7.7)
+ minitest (~> 5.1)
+ thread_safe (~> 0.1)
+ tzinfo (~> 1.1)
+ addressable (2.3.6)
+ builder (3.2.2)
+ descendants_tracker (0.0.4)
+ thread_safe (~> 0.3, >= 0.3.1)
+ docile (1.1.3)
+ faraday (0.9.0)
+ multipart-post (>= 1.2, < 3)
+ git (1.2.6)
+ github_api (0.11.3)
+ addressable (~> 2.3)
+ descendants_tracker (~> 0.0.1)
+ faraday (~> 0.8, < 0.10)
+ hashie (>= 1.2)
+ multi_json (>= 1.7.5, < 2.0)
+ nokogiri (~> 1.6.0)
+ oauth2
+ hashie (3.0.0)
+ highline (1.6.21)
+ i18n (0.6.11)
+ jeweler (2.0.1)
+ builder
+ bundler (>= 1.0)
+ git (>= 1.2.5)
+ github_api
+ highline (>= 1.6.15)
+ nokogiri (>= 1.5.10)
+ rake
+ rdoc
+ json (1.8.1)
+ jwt (1.0.0)
+ mini_portile (0.6.0)
+ minitest (5.4.0)
+ multi_json (1.10.1)
+ multi_xml (0.5.5)
+ multipart-post (2.0.0)
+ nokogiri (1.6.2.1)
+ mini_portile (= 0.6.0)
+ oauth2 (0.9.4)
+ faraday (>= 0.8, < 0.10)
+ jwt (~> 1.0)
+ multi_json (~> 1.3)
+ multi_xml (~> 0.5)
+ rack (~> 1.2)
+ rack (1.5.2)
+ rake (10.3.2)
+ rdoc (3.12.2)
+ json (~> 1.4)
+ shoulda (3.5.0)
+ shoulda-context (~> 1.0, >= 1.0.1)
+ shoulda-matchers (>= 1.4.1, < 3.0)
+ shoulda-context (1.2.1)
+ shoulda-matchers (2.6.1)
+ activesupport (>= 3.0.0)
+ simplecov (0.8.2)
+ docile (~> 1.1.0)
+ multi_json
+ simplecov-html (~> 0.8.0)
+ simplecov-html (0.8.0)
+ thread_safe (0.3.4)
+ tzinfo (1.2.1)
+ thread_safe (~> 0.1)
+
+PLATFORMS
+ ruby
+
+DEPENDENCIES
+ bundler (~> 1.0)
+ jeweler (~> 2.0.1)
+ rdoc (~> 3.12)
+ shoulda
+ simplecov
View
@@ -0,0 +1,51 @@
+# encoding: utf-8
+
+require 'rubygems'
+require 'bundler'
+begin
+ Bundler.setup(:default, :development)
+rescue Bundler::BundlerError => e
+ $stderr.puts e.message
+ $stderr.puts "Run `bundle install` to install missing gems"
+ exit e.status_code
+end
+require 'rake'
+
+require 'jeweler'
+Jeweler::Tasks.new do |gem|
+ # gem is a Gem::Specification... see http://guides.rubygems.org/specification-reference/ for more options
+ gem.name = "jekyll-prism-plugin"
+ gem.homepage = "http://github.com/tomjanssens/jekyll-prism-plugin"
+ gem.license = "MIT"
+ gem.summary = ""
+ gem.description = ""
+ gem.email = "tom@janssens.me"
+ gem.authors = ["Tom Janssens"]
+ # dependencies defined in Gemfile
+end
+Jeweler::RubygemsDotOrgTasks.new
+
+require 'rake/testtask'
+Rake::TestTask.new(:test) do |test|
+ test.libs << 'lib' << 'test'
+ test.pattern = 'test/**/test_*.rb'
+ test.verbose = true
+end
+
+desc "Code coverage detail"
+task :simplecov do
+ ENV['COVERAGE'] = "true"
+ Rake::Task['test'].execute
+end
+
+task :default => :test
+
+require 'rdoc/task'
+Rake::RDocTask.new do |rdoc|
+ version = File.exist?('VERSION') ? File.read('VERSION') : ""
+
+ rdoc.rdoc_dir = 'rdoc'
+ rdoc.title = "jekyll-prism-plugin #{version}"
+ rdoc.rdoc_files.include('README*')
+ rdoc.rdoc_files.include('lib/**/*.rb')
+end
View
@@ -0,0 +1 @@
+0.0.1
@@ -0,0 +1,59 @@
+# Generated by jeweler
+# DO NOT EDIT THIS FILE DIRECTLY
+# Instead, edit Jeweler::Tasks in Rakefile, and run 'rake gemspec'
+# -*- encoding: utf-8 -*-
+# stub: jekyll-prism-plugin 0.0.1 ruby lib
+
+Gem::Specification.new do |s|
+ s.name = "jekyll-prism-plugin"
+ s.version = "0.0.1"
+
+ s.required_rubygems_version = Gem::Requirement.new(">= 0") if s.respond_to? :required_rubygems_version=
+ s.require_paths = ["lib"]
+ s.authors = ["Tom Janssens"]
+ s.date = "2014-07-31"
+ s.description = ""
+ s.email = "tom@janssens.me"
+ s.extra_rdoc_files = [
+ "LICENSE.txt",
+ "README.md"
+ ]
+ s.files = [
+ "Gemfile",
+ "Gemfile.lock",
+ "LICENSE.txt",
+ "README.md",
+ "Rakefile",
+ "VERSION",
+ "lib/jekyll-prism-plugin.rb"
+ ]
+ s.homepage = "http://github.com/tomjanssens/jekyll-prism-plugin"
+ s.licenses = ["MIT"]
+ s.rubygems_version = "2.2.2"
+ s.summary = ""
+
+ if s.respond_to? :specification_version then
+ s.specification_version = 4
+
+ if Gem::Version.new(Gem::VERSION) >= Gem::Version.new('1.2.0') then
+ s.add_development_dependency(%q<shoulda>, [">= 0"])
+ s.add_development_dependency(%q<rdoc>, ["~> 3.12"])
+ s.add_development_dependency(%q<bundler>, ["~> 1.0"])
+ s.add_development_dependency(%q<jeweler>, ["~> 2.0.1"])
+ s.add_development_dependency(%q<simplecov>, [">= 0"])
+ else
+ s.add_dependency(%q<shoulda>, [">= 0"])
+ s.add_dependency(%q<rdoc>, ["~> 3.12"])
+ s.add_dependency(%q<bundler>, ["~> 1.0"])
+ s.add_dependency(%q<jeweler>, ["~> 2.0.1"])
+ s.add_dependency(%q<simplecov>, [">= 0"])
+ end
+ else
+ s.add_dependency(%q<shoulda>, [">= 0"])
+ s.add_dependency(%q<rdoc>, ["~> 3.12"])
+ s.add_dependency(%q<bundler>, ["~> 1.0"])
+ s.add_dependency(%q<jeweler>, ["~> 2.0.1"])
+ s.add_dependency(%q<simplecov>, [">= 0"])
+ end
+end
+
File renamed without changes.

0 comments on commit c8355eb

Please sign in to comment.