Skip to content

Releases: gnugat/redaktilo

Symfony 5 and PHP 7.2

9d0f583
Compare
Choose a tag to compare

Requirements upgraded to Symfony 5 and PHP 7.2

Symfony 4

Compare
Choose a tag to compare
  • added support for Symfony 4

Removed `final` from Editor

Compare
Choose a tag to compare
  • removed final from Editor

Updated dependencies

Compare
Choose a tag to compare
  • added support to Symfony 3
  • added support to PHP 7
  • updated to phpspec 2.4
  • updated to PHPUnit 4.5
  • added support to PHPUnit 5

Brace yourselves, v2 is coming

Compare
Choose a tag to compare
  • added documentation to upgrade to 2.0
  • added Text#map
  • added deprecation messages

Text construction

Compare
Choose a tag to compare
  • added an optional filename argument to Editor#save
  • removed TextFactory
  • removed Text#__construct
  • removed LineBreak
  • added Text#fromArray
  • added Text#fromString
  • added StringUtil#detectLineBreak

Current line number Incrementation

Compare
Choose a tag to compare
  • added Text#decrementCurrentLineNumber
  • added Text#incrementCurrentLineNumber

Exception

Compare
Choose a tag to compare
  • added PatternNotFoundException
  • added NotSupportedException
  • added InvalidLineNumberException
  • added InvalidArgumentException
  • added IOException
  • added FileNotFoundException
  • added DifferentLineBreaksFoundException
  • added CommandNotFoundException
  • added Exception

Chicken Run

Compare
Choose a tag to compare
  • added ContentFactory
  • added LineReplaceAllCommand
  • added Editor#run

Fixed Backward Compatibility Break

Compare
Choose a tag to compare
  • fixed BC break by making command constructor arguments optional