Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

tilix-nautilus doesn’t work anymore in Fedora 27 #1278

Closed
fbruetting opened this Issue Jan 30, 2018 · 20 comments

Comments

Projects
None yet
8 participants
@fbruetting
Copy link

fbruetting commented Jan 30, 2018

Pretty strange… In my older system is works fine since F26, but in two freshly installed F27 VMs, I got no Tilix context menu (whereas gnome-terminal-nautilus works fine when (un)installing).

@gnunn1

This comment has been minimized.

Copy link
Owner

gnunn1 commented Jan 30, 2018

At a command line, if you run nautilus -q to close it and then run nautilus again, what is the output that is shown?

@fbruetting

This comment has been minimized.

Copy link
Author

fbruetting commented Jan 31, 2018

Hi Gerald, here’s the output (there’s absolutely no output with this package not installed):

$ nautilus
ImportError: could not import gobject (error was: 'No module named gi._gobject')

(nautilus:28062): Nautilus-Python-WARNING **: pygobject initialization failed

(nautilus:28062): Nautilus-Python-WARNING **: nautilus_python_init_python failed
@storm119

This comment has been minimized.

Copy link

storm119 commented Feb 2, 2018

Tilix depend on python2-nautilus for open "context menu" to works correctly on Nautilus [correct me if I'm wrong]...but prior installing the python2-nautilus, one need to uninstall the python-nautilus (current version conflicting with python2-nautilus atleast it's happen on my box running Manjaro Arch)

@gnunn1 any chances Tilix will use/integrating with python-nautilus instead of python2-nautilus or make it to work with nautilus-python3 ?

TIA

@phw

This comment has been minimized.

Copy link
Contributor

phw commented Feb 2, 2018

any chances Tilix will use/integrating with python-nautilus instead of python2-nautilus or make it to work with nautilus-python3 ?

Actually it should already work with python3, see #1252 . Which version of Tilix is this?

@storm119

This comment has been minimized.

Copy link

storm119 commented Feb 2, 2018

Actually it should already work with python3, see #1252 . Which version of Tilix is this?

Alrite....my mistake ditched python2-nautilus and rebuild/reinstall Tilix solved my issue...version 1.7.5 btw

@gnunn1

This comment has been minimized.

Copy link
Owner

gnunn1 commented Feb 3, 2018

So is this an issue with the waytilix is packaged in COPR or did you install tilix manually?

@fbruetting

This comment has been minimized.

Copy link
Author

fbruetting commented Feb 3, 2018

I installed it right out of the dnf repo (v1.7.5-1).

@gnunn1

This comment has been minimized.

Copy link
Owner

gnunn1 commented Feb 3, 2018

@fbruetting I think you should open a bug report against that then since this sounds like a package issue to me. If that makes sense to you then please link this issue to that when you do so.

@ykgmfq

This comment has been minimized.

Copy link

ykgmfq commented Feb 7, 2018

Works fine for me, cannot reproduce.

$ dnf list installed|grep tilix
tilix.x86_64                         1.7.5-1.fc27               @updates        
tilix-nautilus.x86_64                1.7.5-1.fc27               @updates
@cra0zy

This comment has been minimized.

Copy link

cra0zy commented Feb 7, 2018

I was able to reproduce it, but looking at the error it seems like the dependency was not getting installed, to fix it run: sudo dnf install pygobject3 python3-gobject

@gnunn1

This comment has been minimized.

Copy link
Owner

gnunn1 commented Feb 10, 2018

I'm closing this as it is not a tilix issue but rather a packaging issue.

@gnunn1 gnunn1 closed this Feb 10, 2018

@ykgmfq

This comment has been minimized.

Copy link

ykgmfq commented Feb 10, 2018

@fbruetting

This comment has been minimized.

Copy link
Author

fbruetting commented Feb 10, 2018

Thanks! Just right now, I was searching for the packager… ^^

@fbruetting

This comment has been minimized.

Copy link
Author

fbruetting commented Feb 10, 2018

@gnunn1 Will it be possible to ship Tilix via flatpak? I know the sandbox thing won’t work, but still it would be more convenient.

@gnunn1

This comment has been minimized.

Copy link
Owner

gnunn1 commented Feb 10, 2018

Yes it is and I think the work is done with respect to fixing the sandbox, it's just a matter of time. If someone wants to volunteer to maintain the flatpak so I don't have to then that would be great.

@gombosg

This comment has been minimized.

Copy link
Contributor

gombosg commented Aug 21, 2018

Still not fixed in Fedora. :(

@cra0zy

This comment has been minimized.

Copy link

cra0zy commented Aug 21, 2018

sudo dnf install pygobject3 python3-gobject

@gombosg

This comment has been minimized.

Copy link
Contributor

gombosg commented Aug 21, 2018

Yes, thanks, I saw it above and fixed for myself already. I mean, the package dependency is not fixed. :)

@bilelmoussaoui

This comment has been minimized.

Copy link
Contributor

bilelmoussaoui commented Aug 21, 2018

@gombosg It was reported to Fedora packagers see https://bugzilla.redhat.com/show_bug.cgi?id=1539039

@fbruetting

This comment has been minimized.

Copy link
Author

fbruetting commented Sep 15, 2018

Is fixed in Fedora 29.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.