New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Gitea crashes at start: pthread_create failed #6031

Open
bodqhrohro opened this Issue Feb 10, 2019 · 8 comments

Comments

4 participants
@bodqhrohro
Copy link

bodqhrohro commented Feb 10, 2019

Description

Screenshots

@lafriks

This comment has been minimized.

Copy link
Member

lafriks commented Feb 10, 2019

Do you have code search enabled?

@bodqhrohro

This comment has been minimized.

Copy link
Author

bodqhrohro commented Feb 10, 2019

I have not done any configuration yet, just downloaded the binary and tried to run it. Do you mean REPO_INDEXER_ENABLED, which is disabled by default?

@lafriks

This comment has been minimized.

Copy link
Member

lafriks commented Feb 10, 2019

yes

@bodqhrohro

This comment has been minimized.

Copy link
Author

bodqhrohro commented Feb 10, 2019

So, no; the auto-generated config has only INTERNAL_TOKEN defined.

@jolheiser

This comment has been minimized.

Copy link
Member

jolheiser commented Feb 11, 2019

Could be related to this issue?
Some CGO threads leaking/not returning?

@typeless

This comment has been minimized.

Copy link
Contributor

typeless commented Feb 11, 2019

Is this reliably reproducible on every launch of Gitea? Or does it happen randomly?

@bodqhrohro

This comment has been minimized.

Copy link
Author

bodqhrohro commented Feb 11, 2019

Could be related to this issue?
Some CGO threads leaking/not returning?

Probably. So I need to make a custom build with CGO_ENABLED=0? Or it would be better to check if pthread_create is permitted on the hosting first?

Is this reliably reproducible on every launch of Gitea? Or does it happen randomly?

On every launch on certain system.

@typeless

This comment has been minimized.

Copy link
Contributor

typeless commented Feb 11, 2019

@bodqhrohro I tested it on Ubuntu 14.04 through docker, and it works. apt-get upgrade your libc and so on might help if it is a library issue (the released Gitea binary seems to be a static executable, so it should have nothing to do with libc).

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment