Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Failed to ailed to initialize issue indexer: leveldb: manifest corrupted (field 'comparer'): missing [file=MANIFEST-000042] #7013

Closed
TheRealKerni opened this issue May 22, 2019 · 6 comments

Comments

@TheRealKerni
Copy link

@TheRealKerni TheRealKerni commented May 22, 2019

  • Gitea version (or commit ref):1.8.1
  • Git version: 2.11.0
  • Operating system: Raspian Stretch
  • Database (use [x]):
    • PostgreSQL
    • MySQL
    • MSSQL
    • SQLite
  • Can you reproduce the bug at https://try.gitea.io:
    • Yes (provide example URL)
    • No
    • Not relevant
  • Log gist:

Description

Gitea 1.8.1 stopped starting up while being without any load somewhen in the middle of the night.

There is no setting in app.ini to set anything related to the issue indexer, so it is using the default settings.

The log file shows:

2019/05/22 11:27:43 [I] Log Mode: File(Info)
2019/05/22 11:27:43 [I] XORM Log Mode: File(Info)
2019/05/22 11:27:43 [I] Cache Service Enabled
2019/05/22 11:27:43 [I] Session Service Enabled
2019/05/22 11:27:43 [I] Mail Service Enabled
2019/05/22 11:27:43 [I] Beginning ORM engine initialization.
2019/05/22 11:27:43 [I] ORM engine initialization attempt #1/10...
2019/05/22 11:27:44 [I] ORM engine initialization successful!
2019/05/22 11:27:44 [I] Git Version: 2.11.0
2019/05/22 11:27:44 [...itea/routers/init.go:95 GlobalInit()] [E] Failed to initialize issue indexer: leveldb: manifest corrupted (field 'comparer'): missing [file=MANIFEST-000042]

Please let me know if there is anything else I can provide.

Thanks for any help,
Andreas

@zeripath

This comment has been minimized.

Copy link
Contributor

@zeripath zeripath commented May 22, 2019

AFAIU You should just be able to delete the indexer files and they should repopulate.

@TheRealKerni

This comment has been minimized.

Copy link
Author

@TheRealKerni TheRealKerni commented May 22, 2019

Ah perfect. That worked!

Thank you.

@IanRCarter

This comment has been minimized.

Copy link

@IanRCarter IanRCarter commented Jun 28, 2019

Sorry to revive a closed issue but I have come across the same problem this morning.

How do you 'delete the indexer files'?

@byumov

This comment has been minimized.

Copy link

@byumov byumov commented Jul 18, 2019

Just remove files:

rm -rf <giteatPath>/gitea/indexers/*
@seichter

This comment has been minimized.

Copy link

@seichter seichter commented Jul 22, 2019

Maybe somebody stopping by: had exactly the same issue and deleting /var/lib/gitea/indexers/* didn't work. There is another folder /var/lib/gitea/data/indexers/*. Emptying this one got me running again.

@S2-

This comment has been minimized.

Copy link

@S2- S2- commented Nov 5, 2019

I had the same issue too, and in my case the indexers folder was in <giteatPath>/gitea/data/indexers/.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
6 participants
You can’t perform that action at this time.