Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Dependency updates #1119

Merged
merged 6 commits into from Jun 24, 2021
Merged

Dependency updates #1119

merged 6 commits into from Jun 24, 2021

Conversation

sagikazarmark
Copy link
Contributor

@sagikazarmark sagikazarmark commented Jun 22, 2021

This PR updates various "smaller" dependencies that doesn't need a separate PR.

Related #1109

@@ -22,28 +22,28 @@ require (
github.com/go-stack/stack v1.8.0
github.com/golang/protobuf v1.5.2
github.com/google/btree v1.0.0 // indirect
github.com/hashicorp/consul/api v1.3.0
github.com/hashicorp/consul/api v1.8.1
Copy link
Member

@ChrisHines ChrisHines Jun 24, 2021

Choose a reason for hiding this comment

The reason will be displayed to describe this comment to others. Learn more.

Looks like v1.9.0 just came out.

Copy link
Contributor Author

@sagikazarmark sagikazarmark Jun 24, 2021

Choose a reason for hiding this comment

The reason will be displayed to describe this comment to others. Learn more.

Thanks! Updated

Copy link
Contributor Author

@sagikazarmark sagikazarmark Jun 24, 2021

Choose a reason for hiding this comment

The reason will be displayed to describe this comment to others. Learn more.

Turns out that 1.9.0 requires Go 1.16 (it uses io.Discard added in that version), so I reverted the update for now. If a decision is made that making Go kit 1.16 only is fine, we can upgrade it, but I'd probably wait for Go 1.17 so we can support at least two versions.

Copy link
Member

@ChrisHines ChrisHines Jun 24, 2021

Choose a reason for hiding this comment

The reason will be displayed to describe this comment to others. Learn more.

OK, good to know. Agreed on maintaining 1.15 compatibility for now. Last I checked the go-kit policy is to support the current and previous Go release.

Signed-off-by: Mark Sagi-Kazar <mark.sagikazar@gmail.com>
Signed-off-by: Mark Sagi-Kazar <mark.sagikazar@gmail.com>
Signed-off-by: Mark Sagi-Kazar <mark.sagikazar@gmail.com>
Signed-off-by: Mark Sagi-Kazar <mark.sagikazar@gmail.com>
Signed-off-by: Mark Sagi-Kazar <mark.sagikazar@gmail.com>
Signed-off-by: Mark Sagi-Kazar <mark.sagikazar@gmail.com>
@sagikazarmark sagikazarmark merged commit 38deb18 into go-kit:master Jun 24, 2021
2 checks passed
@sagikazarmark sagikazarmark deleted the dep-updates branch Jun 24, 2021
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Labels
None yet
Projects
None yet
Development

Successfully merging this pull request may close these issues.

None yet

2 participants