Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

version 6.15.3+ is not usable with Go modules #1149

Closed
pierrre opened this issue Sep 3, 2019 · 2 comments

Comments

@pierrre
Copy link

commented Sep 3, 2019

I'm opening a new issue, because the problem is slightly different.

Before v6.15.2, the repository didn't use Go module, but it was usable in a project using Go modules.
Since v6.15.3, the repository contains a go.mod file that doesn't respect the Go module rules.
Since Go 1.13, the Go module rules are stricter.
You can't install anymore v6.15.3 and v6.15.4 with Go 1.13 (FYI it will be released very soon)
I've opened an issue about this golang/go#34005 and they confirmed that the issue is on go-redis side.

I see a simple solution: remove entirely the Go module support from v6, and release a new tag v6.15.5.

It seems that v7 is using the Go module correctly, but it's still in beta.

WDYT ?

@vmihailenco

This comment has been minimized.

Copy link
Contributor

commented Sep 3, 2019

Works for me. Could you send a PR to the v6 branch?

@pierrre

This comment has been minimized.

Copy link
Author

commented Sep 3, 2019

Or maybe it's caused by the new go 1.13 line in go.mod, I don't know.
But anyway, v6 is not compatible with Go module, so we should remove go.mod.
I'll send a PR.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
2 participants
You can’t perform that action at this time.