Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Setup referencing wrong path, causing setup failure #1817

Closed
mjboroski opened this issue Oct 26, 2019 · 1 comment

Comments

@mjboroski
Copy link

@mjboroski mjboroski commented Oct 26, 2019

Description

I found a bug.

Steps to Reproduce the Problem

  1. buffalo new myapp -v

Expected Behavior

"buffalo new" should work

Actual Behavior

it didn't

Info

NOTICE THE DOUBLING OF "\myapp" IN THE LAST LINE'S PATH
This is probably just a path variable fix, but I don't know where to even begin digging through the code to find it.

...
DEBU[2019-10-26T16:42:33-04:00] Step: 5488397b
DEBU[2019-10-26T16:42:33-04:00] Chdir: C:\Users\username\go\myapp
DEBU[2019-10-26T16:42:33-04:00] File: C:/Users/username/go/myapp/config/buffalo-plugins.toml
DEBU[2019-10-26T16:42:33-04:00] Step: c35a71ae
DEBU[2019-10-26T16:42:33-04:00] Chdir: C:\Users\username\go\myapp
DEBU[2019-10-26T16:42:33-04:00] Exec: go get -t ./...
grifts\init.go:5:2: cannot find package "../myapp/actions" in:
C:\Users\username\go\myapp\myapp\actions

@mjboroski mjboroski changed the title Setup referencing wrong path, causing steup failure Setup referencing wrong path, causing setup failure Oct 26, 2019
@markbates

This comment has been minimized.

Copy link
Member

@markbates markbates commented Nov 16, 2019

https://gobuffalo.io/en/docs/gomods/

If you run buffalo info it will tell you the problem.

@markbates markbates closed this Nov 16, 2019
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
3 participants
You can’t perform that action at this time.