Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Unable to solve the dependency graph: jackc/chunkreader #1827

Open
Icaro-Lima opened this issue Nov 8, 2019 · 0 comments
Labels

Comments

@Icaro-Lima
Copy link

@Icaro-Lima Icaro-Lima commented Nov 8, 2019

Description

When i do dep init, the following errors occur:

init failed: unable to solve the dependency graph: Solving failure: No versions of github.com/jackc/chunkreader met constraints:
        v2.0.0: Could not introduce github.com/jackc/chunkreader@v2.0.0, as its subpackage github.com/jackc/chunkreader/v2 is missing. (Package is required by github.com/jackc/pgconn@master.)
        v1.0.0: Could not introduce github.com/jackc/chunkreader@v1.0.0, as its subpackage github.com/jackc/chunkreader/v2 is missing. (Package is required by github.com/jackc/pgconn@master.)
        master: Could not introduce github.com/jackc/chunkreader@master, as its subpackage github.com/jackc/chunkreader/v2 is missing. (Package is required by github.com/jackc/pgconn@master.)

Steps to Reproduce the Problem

  1. buffalo new coke --api
  2. cd coke
  3. dep init

Info

-> Go: Checking installation
✓ The `go` executable was found on your system at: /usr/local/go/bin/go

-> Go: Checking minimum version requirements
✓ Your version of Go, 1.13, meets the minimum requirements.

-> Go: Checking GOPATH
✓ You appear to be operating inside of your GOPATH.

-> Go: Checking Package Management
⚠ You do not appear to be using a package management system.

It is strongly suggested that you use one of the following package management systems:

* Go Modules (Recommended) - https://gobuffalo.io/en/docs/gomods
* Dep - https://github.com/golang/dep

For help setting up your Go environment please follow the instructions for you platform at:

https://www.gopherguides.com/courses/preparing-your-environment-for-go-development

-> Go: Checking PATH
✓ Your PATH contains /home/icaro-lima/go/bin.

-> Node: Checking installation
✘ The `node` executable could not be found on your system.
For help setting up your Node environment please follow the instructions for you platform at:

https://nodejs.org/en/download/

-> NPM: Checking installation
✘ The `npm` executable could not be found on your system.
For help setting up your NPM environment please follow the instructions for you platform at:

https://docs.npmjs.com/getting-started/configuring-your-local-environment

-> Yarn: Checking installation
✘ The `yarnpkg` executable could not be found on your system.
For help setting up your Yarn environment please follow the instructions for you platform at:

https://yarnpkg.com/en/docs/install

-> PostgreSQL: Checking installation
✘ The `postgres` executable could not be found on your system.
For help setting up your Postgres environment please follow the instructions for you platform at:

https://www.postgresql.org/download/

-> MySQL: Checking installation
✘ The `mysql` executable could not be found on your system.
For help setting up your MySQL environment please follow the instructions for you platform at:

https://www.mysql.com/downloads/

-> SQLite3: Checking installation
✘ The `sqlite3` executable could not be found on your system.
For help setting up your SQLite3 environment please follow the instructions for you platform at:

https://www.sqlite.org/download.html

-> Cockroach: Checking installation
✘ The `cockroach` executable could not be found on your system.
For help setting up your Cockroach environment please follow the instructions for you platform at:

https://www.cockroachlabs.com/docs/stable/

-> Buffalo (CLI): Checking installation
✓ The `buffalo` executable was found on your system at: /usr/local/bin/buffalo

-> Buffalo (CLI): Checking minimum version requirements
✓ Your version of Buffalo (CLI), v0.15.0, meets the minimum requirements.

-> Buffalo: Application Details
Pwd         /home/icaro-lima/go/src/github.com/icaro-lima/coke
Root        /home/icaro-lima/go/src/github.com/icaro-lima/coke
GoPath      /home/icaro-lima/go
PackagePkg  github.com/icaro-lima/coke
ActionsPkg  github.com/icaro-lima/coke/actions
ModelsPkg   github.com/icaro-lima/coke/models
GriftsPkg   github.com/icaro-lima/coke/grifts
WithModules false
Name        coke
Bin         bin/coke
VCS         git
WithPop     true
WithSQLite  false
WithDep     false
WithWebpack false
WithNodeJs  false
WithYarn    false
WithDocker  true
WithGrifts  true
AsWeb       false
AsAPI       true
InApp       true
PackageJSON {map[]}

-> Buffalo: config/buffalo-app.toml
name = "coke"
bin = "bin/coke"
vcs = "git"
with_pop = true
with_sqlite = false
with_dep = false
with_webpack = false
with_nodejs = false
with_yarn = false
with_docker = true
with_grifts = true
as_web = false
as_api = true

-> Buffalo: config/buffalo-plugins.toml
[[plugin]]
  binary = "buffalo-pop"
  go_get = "github.com/gobuffalo/buffalo-pop"
@stanislas-m stanislas-m added the deps-dep label Nov 9, 2019
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
2 participants
You can’t perform that action at this time.