InvalidApiUsageException when listing all enabled CustomerBankAccounts #5

Closed
mikefitz888 opened this Issue Aug 31, 2017 · 2 comments

Comments

Projects
None yet
3 participants
@mikefitz888

Hi, I'm getting an error message of No subschema in \"anyOf\" matched.

Resulting from this call:
Client.CustomerBankAccounts.All(new CustomerBankAccountListRequest { Customer = id, Enabled = true })

Some brief testing suggests it's due to the Enabled parameter.

As per https://github.com/gocardless/gocardless-pro-php/issues/24

It may be due to using True instead of true in the request uri.

e.g. https://api-sandbox.gocardless.com/customer_bank_accounts?customer=CU000000000000&enabled=True

@georgemabey

This comment has been minimized.

Show comment Hide comment
@georgemabey

georgemabey Sep 1, 2017

Hi @mikefitz888,

Thanks for reporting this.

We'd certainly expect True to work here.

We're currently working on a fix. We'll make sure to let you know when we have an update!

Hi @mikefitz888,

Thanks for reporting this.

We'd certainly expect True to work here.

We're currently working on a fix. We'll make sure to let you know when we have an update!

@georgemabey

This comment has been minimized.

Show comment Hide comment
@georgemabey

georgemabey Sep 1, 2017

Hey again @mikefitz888!

We've just released a patch to fix this specific bug.

You can find the release notes here - https://github.com/gocardless/gocardless-dotnet/releases/tag/v2.0.6

We hope this helps!

Hey again @mikefitz888!

We've just released a patch to fix this specific bug.

You can find the release notes here - https://github.com/gocardless/gocardless-dotnet/releases/tag/v2.0.6

We hope this helps!

@jacobpgn jacobpgn closed this Sep 1, 2017

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment