Permalink
Browse files

Rename TEST_ENV to RAILS_VERSION

  • Loading branch information...
1 parent 1ae706b commit 3f6e69fdf98902c99cf6caedd4b6017a00c08e7b @justincampbell justincampbell committed Jun 6, 2012
Showing with 11 additions and 11 deletions.
  1. +6 −6 .travis.yml
  2. +5 −5 capistrano-notifier.gemspec
View
@@ -1,9 +1,9 @@
env:
- - TEST_ENV=default
- - TEST_ENV=rails-2.3
- - TEST_ENV=rails-3.0
- - TEST_ENV=rails-3.1
- - TEST_ENV=rails-3.2
+ - RAILS_VERSION=none
+ - RAILS_VERSION=2.3
+ - RAILS_VERSION=3.0
+ - RAILS_VERSION=3.1
+ - RAILS_VERSION=3.2
rvm:
- 1.8.7
- 1.9.2
@@ -19,7 +19,7 @@ matrix:
- rvm: ruby-head
exclude:
- rvm: ruby-head
- env: TEST_ENV=rails-2.3
+ env: RAILS_VERSION=2.3
notifications:
email:
- sysadmin@cramerdev.com
@@ -15,14 +15,14 @@ Gem::Specification.new do |gem|
gem.require_paths = ["lib"]
gem.version = Capistrano::Notifier::VERSION
- case ENV['TEST_ENV']
- when 'rails-2.3'
+ case ENV['RAILS_VERSION']
+ when '2.3'
gem.add_dependency 'actionmailer', '~> 2.3.0'
- when 'rails-3.0'
+ when '3.0'
gem.add_dependency 'actionmailer', '~> 3.0.0'
- when 'rails-3.1'
+ when '3.1'
gem.add_dependency 'actionmailer', '~> 3.1.0'
- when 'rails-3.2'
+ when '3.2'
gem.add_dependency 'actionmailer', '~> 3.2.0'
else
gem.add_dependency 'actionmailer'

0 comments on commit 3f6e69f

Please sign in to comment.