Skip to content
Permalink
master
Switch branches/tags
Go to file
 
 
Cannot retrieve contributors at this time
name
Installation

Prerequisites

  • Database (choose one of the following):
    • MySQL: Version >= 5.7
    • PostgreSQL
    • TiDB (experimental, connect via the MySQL protocol)
    • or NOTHING with SQLite3
  • Git (bash):
    • Version >= 1.8.3 for both server and client sides
    • Best to use latest version for Windows
  • A functioning SSH server:
    • Ignore this if you're only going to use HTTP/HTTPS
    • For using builtin SSH server on Windows, make sure you added ssh-keygen to your %PATH% environment variable.
    • For using standalone SSH server, recommend Cygwin OpenSSH or Copssh for Windows.
    • For Windows servers, please make sure Bash is the default shell not PowerShell.

Install database

Based on your choice, install one of the supported databases (or skip this step):

REMEMBER Please use scripts/mysql.sql to create a database called gogs (default). If you create it manually, make sure the encoding is utf8mb4.

Install additional requirements

Mac OS X

Assuming you have Homebrew already installed:

$ brew update
$ brew install git

Debian/Ubuntu

$ sudo apt-get update
$ sudo apt-get install git

Fedora

$ sudo dnf update
$ sudo dnf install git

RHEL/CentOS

$ sudo yum update
$ sudo yum install git

Windows

Download and install Git

Install Gogs