New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Page creation issue for taxonomies without _index.md 0.18.1 #2992

Closed
jeffreycentex opened this Issue Jan 27, 2017 · 1 comment

Comments

Projects
None yet
2 participants
@jeffreycentex

The basic problem is thus: I can specify a _index.md for a category or a tag (i.e., taxonomy terms), but only the categories and tags items that have had the _index.md generate pages. The other taxonomy terms that I want to use the default for are not generated, resulting in a 404 error.

In my config.toml file, I have the following set:

[taxonomies]
  tag = "tags"
  category = "categories"

I will use tags as my example as I do have some custom templates for my categories on my blog.

Under content, I have a folder for tags. Inside tags, I have two folders that match 2 of my approximately 15 tags. Inside these two folders, I have an _index.md file.

When I run hugo (and as can be seen by the current version of my website hosted on gitlab), only the two pages I specified in the /content/tags folder generated pages - not the overall list which is what happens if I remove the /content/tags folder.

For categories, I only had 5 so I specified each in the /contents/categories folder and all of them generated...

For all the taxonomy pages generated, the index.xml (RSS) was created for files that had the _index.md file created, but not for any that didn't.

This is for hugo 0.18.1 and happens on Windows, Ubuntu 16.10, and on the gitlab build server,

https://gitlab.com/jeffreycentex/jeffreycentex.gitlab.io is my current repo that has the issue (Commit c7bfa5d8) and the content is live on https://jeffreycentex.gitlab.io (the tag list is on the main page in the sidebar)

@jeffreycentex

This comment has been minimized.

Show comment
Hide comment
@jeffreycentex

jeffreycentex Feb 2, 2017

It seems that this happens sporadically.. I run build after build of the website and I will get different tag and category pages generated each time. So the problem is more that hugo does not build this content consistently...

It seems that this happens sporadically.. I run build after build of the website and I will get different tag and category pages generated each time. So the problem is more that hugo does not build this content consistently...

@bep bep self-assigned this Feb 17, 2017

@bep bep added this to the v0.19 milestone Feb 17, 2017

@bep bep added the Bug label Feb 18, 2017

bep added a commit to bep/hugo that referenced this issue Feb 18, 2017

@bep bep closed this in 4493e8e Feb 18, 2017

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment