New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Config changes does not properly reload in server mode #4878

Open
bep opened this Issue Jun 25, 2018 · 6 comments

Comments

Projects
None yet
5 participants
@bep
Member

bep commented Jun 25, 2018

Not sure when that happened.

/cc @anthonyfok

@bep bep added the Bug label Jun 25, 2018

@bep bep added this to the v0.43 milestone Jun 25, 2018

@bep bep self-assigned this Jun 25, 2018

@GrandNewbien

This comment has been minimized.

GrandNewbien commented Jun 26, 2018

I thought this was related to issue #4424, where I can confirm double write events on my own machine.

@bep

This comment has been minimized.

Member

bep commented Jun 26, 2018

@GrandNewbien this is a fairly new regression -- we are lacking in test coverage in this area, but I'm using this all the time ...

@bep bep closed this in 2955f93 Jun 28, 2018

bep added a commit that referenced this issue Jun 28, 2018

commands: Fix broken server-reload on config changes
This was accidently broken in Hugo 0.42.

Fixes #4878
@almai

This comment has been minimized.

almai commented Jul 26, 2018

Server reload happens only once after the first change of config.toml. 2nd change doesn't get recognized. No output in debug or verbose mode.

Running on v0.45.1, macOS 10.13.5

@primercuervo

This comment has been minimized.

primercuervo commented Aug 9, 2018

I'm facing the same as @almai reports. Running on Ubuntu 18.04. Reload works the first time as expected, but in order to see the changes after that I have to manually restart the server

$ hugo version
Hugo Static Site Generator v0.40.1 linux/amd64 BuildDate: 2018-04-25T17:16:11Z
@primercuervo

This comment has been minimized.

primercuervo commented Aug 9, 2018

Just tested it with the latest release

$ hugo version
Hugo Static Site Generator v0.46 linux/amd64 BuildDate: 2018-08-01T09:00:55Z

running just hugo server or adding the --disableFastRender and/or --ignoreCache yields to the same result (reload working only once)

@bep bep reopened this Aug 9, 2018

@anthonyfok

This comment has been minimized.

Contributor

anthonyfok commented Aug 9, 2018

I wonder if this and #4701 (and #4224 mentioned above) are related. Need to take a closer look again.
(Sorry I left #4701 and #4720 stale for too long.)

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment