New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

hugo server -t still doesn't work #5569

Closed
felicianotech opened this Issue Dec 27, 2018 · 5 comments

Comments

Projects
None yet
5 participants
@felicianotech
Copy link
Contributor

felicianotech commented Dec 27, 2018

Running hugo server -t <a theme> still doesn't work.

There's several related Issues, some open and some closed:

This issue goes back to 10 months ago when support for theme config was added.

I haven't been able to track down exactly where the issue is myself, but I did notice that here (

v1.Set("allThemes", themeConfigs)
) is where the theme passed by the CLI gets lost. If i disable that line, it works as expected though the tests fail.

@moorereason

This comment has been minimized.

Copy link
Contributor

moorereason commented Dec 27, 2018

Pro Tip: Reference a specific commit hash when linking to a line in a file; otherwise, the link will not work if the file changes in master.

@felicianotech

This comment has been minimized.

Copy link
Contributor Author

felicianotech commented Dec 27, 2018

Good point. I've updated the link.

@moorereason moorereason added the Bug label Dec 27, 2018

@tryzniak

This comment has been minimized.

Copy link
Contributor

tryzniak commented Jan 11, 2019

I've been working on this issue, and looks like soon it's going to be resolved ;)

@anthonyfok

This comment has been minimized.

Copy link
Contributor

anthonyfok commented Jan 12, 2019

See also #5061 (as in if this bug is fixed, #5061 can be closed too.) :-)

@tryzniak

This comment has been minimized.

Copy link
Contributor

tryzniak commented Jan 12, 2019

tryzniak added a commit to tryzniak/hugo that referenced this issue Jan 13, 2019

Make hugo server -t work again
This commit solves an issue where hugo would ignore the cli -t flag
and only use a theme defined in config.toml.

Also allow -t flag to accept a string slice.

Closes gohugoio#5569
Closes gohugoio#5061
Related gohugoio#4868

@bep bep closed this in #5603 Jan 13, 2019

bep added a commit that referenced this issue Jan 13, 2019

Make hugo server -t work again
This commit solves an issue where hugo would ignore the cli -t flag
and only use a theme defined in config.toml.

Also allow -t flag to accept a string slice.

Closes #5569
Closes #5061
Related #4868

@bep bep added this to the v0.54 milestone Jan 13, 2019

nguyenvanduocit added a commit to 12bitvn/hugo that referenced this issue Jan 18, 2019

Make hugo server -t work again
This commit solves an issue where hugo would ignore the cli -t flag
and only use a theme defined in config.toml.

Also allow -t flag to accept a string slice.

Closes gohugoio#5569
Closes gohugoio#5061
Related gohugoio#4868
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment