Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

'watch' not working in vim on MacOS (0.56.*) #6139

Closed
law opened this issue Jul 30, 2019 · 0 comments

Comments

@law
Copy link

commented Jul 30, 2019

After upgrading to 0.56.1, the ‘watch’ functionality of ‘hugo server’ seems to be selectively working. Specifically, running “hugo server -D --disableFastRender” (or any permutation) says it is monitoring the config.toml file and the various “site/{archetypes,content,data,layouts,static,themes}” directories, but changes to some pick up and are rendered while changes to others (specifically my config.toml file) are not. I took the liberty of creating a GIF illustrating the problem directly:
https://recordit.co/WrNqLVxmM9

Yes, I know the gif shows 0.56.0, but I've reproduced the same behavior at 0.56.1.

@bep bep changed the title 0.56.1 'watch' not working 'watch' not working Jul 30, 2019

@bep bep changed the title 'watch' not working 'watch' not working in vim on MacOS (0.56.*) Jul 30, 2019

@bep bep added this to the v0.56.2 milestone Jul 30, 2019

@bep bep closed this in 6eca0a3 Jul 30, 2019

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
2 participants
You can’t perform that action at this time.