Skip to content
Permalink
Branch: master
Find file Copy path
Find file Copy path
4 contributors

Users who have contributed to this file

@bep @yarko @RickCogley @anthonyfok
57 lines (38 sloc) 2.51 KB
title linktitle description date categories menu keywords weight toc aliases
Frequently Asked Questions
FAQ
Solutions to some common Hugo problems.
2018-02-10
troubleshooting
docs
parent
troubleshooting
faqs
2
true
/faq/

{{% note %}} Note: The answers/solutions presented below are short, and may not be note be enough to solve your problem. Visit Hugo Discourse and use the search. It that does not help, start a new topic and ask your questions. {{% /note %}}

I can't see my content!

Is your markdown file in draft mode? When testing, run hugo server with the -D or --buildDrafts switch.

Can I set configuration variables via OS environment?

Yes you can! See Configure with Environment Variables.

How do I schedule posts?

  1. Set publishDate in the page Front Matter to a date in the future.
  2. Build and publish at intervals.

How to automate the "publish at intervals" part depends on your situation:

  • If you deploy from your own PC/server, you can automate with Cron or similar.
  • If your site is hosted on a service similar to Netlify you can use a service such as ifttt to schedule the updates.

Also see this Twitter thread:

{{< tweet 962380712027590657 >}}

Can I use the latest Hugo version on Netlify?

Yes you can! Read this.

I get "TOCSS ... this feature is not available in your current Hugo version"

If you process SCSS or SASS to CSS in your Hugo project, you need the Hugo extended version, or else you may see this error message:

error: failed to transform resource: TOCSS: failed to transform "scss/main.scss" (text/x-scss): this feature is not available in your current Hugo version

We release two set of binaries for technical reasons. The extended is not what you get by default, as an example, when you run brew install hugo on macOS. On the release page, look for archives with extended in the name. To build hugo-extended, use go install --tags extended

To confirm, run hugo version and look for the word extended.

You can’t perform that action at this time.