Skip to content
This repository

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Newer
Older
100644 46 lines (41 sloc) 1.789 kb
7501ad1e »
2012-01-29 Commit the pypi structure
1 # -*- coding: utf-8 -*-
2 # Copyright (c) 2011 by Pablo Martín <goinnn@gmail.com>
3 #
4 # This software is free software: you can redistribute it and/or modify
5 # it under the terms of the GNU Lesser General Public License as published by
6 # the Free Software Foundation, either version 3 of the License, or
7 # (at your option) any later version.
8 #
9 # This software is distributed in the hope that it will be useful,
10 # but WITHOUT ANY WARRANTY; without even the implied warranty of
11 # MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
12 # GNU Lesser General Public License for more details.
13 #
14 # You should have received a copy of the GNU Lesser General Public License
15 # along with this software. If not, see <http://www.gnu.org/licenses/>.
16
17 import os
18 from setuptools import setup
19
20
21 def read(*rnames):
22 return open(os.path.join(os.path.dirname(__file__), *rnames)).read()
5f3f6e00 »
2012-03-02 Refactored and fix some error
23
24
7501ad1e »
2012-01-29 Commit the pypi structure
25 setup(
26 name='Kate-plugins',
97decbb0 »
2012-06-15 Detail to jQuery autocomplete. This do not accept something kile this…
27 version="0.1.4",
7501ad1e »
2012-01-29 Commit the pypi structure
28 description="Plugins to Kate editor to develop faster python projects, django projects and something of javascript",
29 long_description=(read('README.rst') + '\n\n' + read('CHANGES')),
30 author="Pablo Martin",
31 author_email="goinnn@gmail.com",
32 url="https://github.com/goinnn/Kate-plugins",
3b9a1e05 »
2012-07-09 Liberate pyplete and add copyright to the python files
33 license="GNU Lesser General Public License",
7501ad1e »
2012-01-29 Commit the pypi structure
34 classifiers=[
35 "Development Status :: 4 - Beta",
36 "Environment :: Plugins",
37 "Intended Audience :: Developers",
38 "Natural Language :: English",
39 "Programming Language :: Python :: 2.6",
40 "Topic :: Software Development",
41 ],
42 packages=('kate_plugins', ),
0a5d854c »
2012-03-02 Details
43 keywords="kate,pate,plugins,kate plugins,pate plugins,python,autocomplete,autocomplete python,django,jquery,js,checker,pep8,pyflakes,jslint",
7501ad1e »
2012-01-29 Commit the pypi structure
44 include_package_data=True,
45 zip_safe=False,
46 )
Something went wrong with that request. Please try again.