Skip to content
Browse files

Fix an error in jQuery autocomplete and js autocomplete

  • Loading branch information...
1 parent 3d8695e commit 534fbb90102783ddc093a9ce23b09b5bfcd0d440 @goinnn committed Oct 29, 2012
View
5 CHANGES
@@ -1,6 +1,11 @@
Releases
========
+0.1.8 (2012-09-02)
+-------------------
+
+* Fix an error in jQuery autocomplete and js autocomplete, broken `in this commit <https://github.com/goinnn/Kate-plugins/commit/de7453f94341f84f5fab36d277a7f8383e961121>`>_
+
0.1.7 (2012-09-02)
-------------------
View
2 kate_plugins/autopate.py
@@ -172,7 +172,7 @@ def completionInvoked(self, view, word, invocationType):
return
for child, attrs in children.items():
index = self.createItemAutoComplete(text=child,
- icon=attrs.get('icon', 'unknown'),
+ category=attrs.get('category', None),
args=attrs.get('args', None),
description=attrs.get('description', None))
if not index:
View
2 kate_plugins/jste_plugins/autocomplete.py
@@ -35,7 +35,7 @@ class StaticJSCodeCompletionModel(AbstractJSONFileCodeCompletionModel):
def __init__(self, *args, **kwargs):
super(StaticJSCodeCompletionModel, self).__init__(*args, **kwargs)
- self.json['window'] = {'icon': 'module', 'children': {}}
+ self.json['window'] = {'category': 'module', 'children': {}}
def getLastExpression(self, line, operators=None):
expr = super(StaticJSCodeCompletionModel, self).getLastExpression(line,
View
29,302 kate_plugins/jste_plugins/autocomplete_jquery.json
14,651 additions, 14,651 deletions not shown because the diff is too large. Please use a local Git client to view these changes.
View
2 kate_plugins/jste_plugins/autocomplete_jquery.json.gen
@@ -10,7 +10,7 @@ to these:
$(document).ready(function () {
result = {}
result['jQuery']['children'] = kateGetJSAutocomplete(jQuery, 5);
- result['jQuery']['icon'] = 'module';
+ result['jQuery']['category'] = 'module';
result['___object'] = kateGetJSAutocomplete(jQuery('body'), 3);
result = JSON.stringify(result);
});
View
10 kate_plugins/jste_plugins/autocomplete_js.gen
@@ -1,5 +1,5 @@
/* File generated with this script: */
-function kateGetIcon(child, childKey) {
+function kateGetCategory(child, childKey) {
if (!child) {
return "constant";
}
@@ -58,16 +58,16 @@ function kateGetJSAutocomplete(obj, levelmax, level, dict) {
}
dict[childKey] = {"children": children};
if (child != undefined) {
- var icon = kateGetIcon(child, childKey);
- dict[childKey]["icon"] = icon;
- if (icon == "function") {
+ var category = kateGetCategory(child, childKey);
+ dict[childKey]["category"] = category;
+ if (category == "function") {
var args = kateGetArgs(child);
if (args) {
dict[childKey]["args"] = kateGetArgs(child);
}
}
} else {
- dict[childKey]["icon"] = "constant";
+ dict[childKey]["category"] = "constant";
}
}
}
View
18,400 kate_plugins/jste_plugins/autocomplete_js.json
9,200 additions, 9,200 deletions not shown because the diff is too large. Please use a local Git client to view these changes.
View
2 setup.py
@@ -24,7 +24,7 @@ def read(*rnames):
setup(
name='Kate-plugins',
- version="0.1.7",
+ version="0.1.8",
description="Plugins to Kate editor to develop faster python projects, django projects and something of javascript",
long_description=(read('README.rst') + '\n\n' + read('CHANGES')),
author="Pablo Martin",

0 comments on commit 534fbb9

Please sign in to comment.
Something went wrong with that request. Please try again.