Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Consider updating to a newer version of github.com/golang/protobuf module #194

Open
dmitshur opened this issue Mar 1, 2019 · 0 comments

Comments

Projects
None yet
1 participant
@dmitshur
Copy link
Member

commented Mar 1, 2019

The current latest release of this google.golang.org/appengine module requires version v1.2.0 of the github.com/golang/protobuf module.

PR golang/protobuf#808 was merged in protobuf recently, removing its requirement on the largely-unused google.golang.org/genproto module. It's likely a new tagged release of protobuf will follow soon (/cc @dsnet).

This issue is for appengine module to consider updating its required version of protobuf module from v1.2.0 to the upcoming newer version. That will reduce the list of dependencies of the appengine module, and in turn anyone that requires this module. Thanks!

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.