Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

runtime, syscall: Plan 9 ARM assembly code should use "SWI $0" instead of "SWI 0" #20378

Closed
cherrymui opened this issue May 16, 2017 · 3 comments

Comments

Projects
None yet
3 participants
@cherrymui
Copy link
Contributor

commented May 16, 2017

On other systems it is all written as SWI $const. We should do the same on Plan 9.
Found by CL https://go-review.googlesource.com/c/43552/.

Leave for Go 1.10.

@cherrymui cherrymui added this to the Go1.10 milestone May 16, 2017

@cherrymui cherrymui self-assigned this May 16, 2017

@gopherbot

This comment has been minimized.

Copy link

commented May 16, 2017

CL https://golang.org/cl/43533 mentions this issue.

@bradfitz

This comment has been minimized.

Copy link
Member

commented May 16, 2017

I think this is safe enough to fix for Go 1.9, especially if it unblocks that other CL (assuming people want it in for Go 1.9). Your call.

@cherrymui

This comment has been minimized.

Copy link
Contributor Author

commented May 16, 2017

Changed the CL targeting Go 1.9.

@gopherbot gopherbot closed this in 3b263e4 May 16, 2017

@golang golang locked and limited conversation to collaborators May 16, 2018

Sign up for free to subscribe to this conversation on GitHub. Already have an account? Sign in.
You can’t perform that action at this time.