Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

x/mobile: Gomobile does not support ARMv5 builds for Android #22108

Closed
Nutomic opened this issue Oct 2, 2017 · 3 comments

Comments

Projects
None yet
4 participants
@Nutomic
Copy link

commented Oct 2, 2017

When building an apk with gomobile build, the resulting apk only contains libraries for the following architectures: arm64-v8a, armeabi-v7a, x86, x86_64. I also tried the following commands:

gomobile build -o basic.apk -target=android/arm golang.org/x/mobile/example/basic
GOARCH=arm GOARM=5 gomobile build -target android -o basic.apk golang.org/x/mobile/example/basic
gomobile build -o o.apk -target=android/armeabi golang.org/x/mobile/example/basic

None of them resulted in an armeabi library, always armeabi-v7a. The same problem exists with the gomobile gradle plugin.

What version of Go are you using (go version)?

go version go1.9 linux/amd64
gomobile version +e095d65 Sun Sep 10 23:20:06 2017
gradle plugin: "gradle.plugin.org.golang.mobile.bind2:gobindPlugin:0.2.5"

Original forum thread

@gopherbot gopherbot added this to the Unreleased milestone Oct 2, 2017

@gopherbot gopherbot added the mobile label Oct 2, 2017

@karalabe

This comment has been minimized.

Copy link
Contributor

commented Oct 2, 2017

As far as I know, the minimum Android version gomobile supports is 4.0 (API 15), which requires ARMv7 already.

@Nutomic

This comment has been minimized.

Copy link
Author

commented Oct 2, 2017

Is there a source for this? I found this stackoverflow answer, but it's not clear if the ARMv7 requirement starts at Android 4.0 or 4.4.

Besides, these are the official specs, as mentioned in the answer, it would be possible to modify newer Android versions to run on ARMv5 (eg custom ROMs or hardware released without Google Play).

Edit: Here's a list oft devices that received an update to 4.0 after release. I assume many of them don't have ARMv7.

@davecheney

This comment has been minimized.

Copy link
Contributor

commented Oct 8, 2017

Gomobile requires ARMv7. It may be possible that there exist android devices that are not ARMv7 compatible, but gomobile does not support them.

@davecheney davecheney closed this Oct 8, 2017

@golang golang locked and limited conversation to collaborators Oct 8, 2018

Sign up for free to subscribe to this conversation on GitHub. Already have an account? Sign in.
You can’t perform that action at this time.