Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

misc/swig/stdio: old swig version causes all.bash to fail #22858

Closed
ALTree opened this issue Nov 23, 2017 · 2 comments

Comments

Projects
None yet
3 participants
@ALTree
Copy link
Member

commented Nov 23, 2017

$ go version
go version devel +8a092b7 Thu Nov 23 04:07:39 2017 +0000 linux/amd64

all.bash started failing with this error

##### ../misc/swig/stdio
go build XXX/go/misc/swig/stdio: must have SWIG version >= 3.0.6
FAIL	XXX/go/misc/swig/stdio [build failed]
2017/11/23 10:35:08 Failed: exit status 1

##### ../misc/swig/callback
go build XXX/go/misc/swig/callback: must have SWIG version >= 3.0.6
FAIL	XXX/go/misc/swig/callback [build failed]
2017/11/23 10:35:09 Failed: exit status 1

On a machine where

$ swig -version

SWIG Version 2.0.10

An old swig version should cause the tests to be skipped (like we do when swig is not installed at all), not trigger an all.bash failure.

@ALTree ALTree added this to the Go1.10 milestone Nov 23, 2017

@ianlancetaylor

This comment has been minimized.

Copy link
Contributor

commented Dec 7, 2017

@ALTree can you see if https://golang.org/cl/82415 fixes the problem for you? Thanks.

@gopherbot

This comment has been minimized.

Copy link

commented Dec 7, 2017

Change https://golang.org/cl/82415 mentions this issue: cmd/dist: only test SWIG if we have a new enough version

@gopherbot gopherbot closed this in 44f241b Dec 7, 2017

@golang golang locked and limited conversation to collaborators Dec 7, 2018

Sign up for free to subscribe to this conversation on GitHub. Already have an account? Sign in.
You can’t perform that action at this time.