Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

x/vgo: does not support "-unstable" gopkg.in imports #23996

Closed
alecthomas opened this issue Feb 21, 2018 · 1 comment

Comments

@alecthomas
Copy link

commented Feb 21, 2018

Please answer these questions before submitting your issue. Thanks!

What version of Go are you using (go version)?

1.10

Does this issue reproduce with the latest release?

Yes.

What operating system and processor architecture are you using (go env)?

Darwin

What did you do?

Ran vgo build on a package that imports gopkg.in/alecthomas/kingpin.v3-unstable.

What did you expect to see?

Success.

What did you see instead?

Lack of success:

vgo: import "github.com/alecthomas/substrate/cmd/substrated" ->
	import "gopkg.in/alecthomas/kingpin.v3-unstable": invalid gopkg.in/ path: "gopkg.in/alecthomas/kingpin.v3-unstable"

@alecthomas alecthomas changed the title vgo does not support "-unstable" gopkg.in imports x/vgo: does not support "-unstable" gopkg.in imports Feb 21, 2018

@gopherbot gopherbot added this to the vgo milestone Feb 21, 2018

@alecthomas

This comment has been minimized.

Copy link
Author

commented Feb 21, 2018

Apologies. Duplicate of #23989.

@alecthomas alecthomas closed this Feb 21, 2018

@golang golang locked and limited conversation to collaborators Feb 21, 2019

Sign up for free to subscribe to this conversation on GitHub. Already have an account? Sign in.
Projects
None yet
2 participants
You can’t perform that action at this time.