Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

proposal: x/vgo: specify Go version required by module #24714

Closed
dpinela opened this issue Apr 5, 2018 · 2 comments

Comments

@dpinela
Copy link
Contributor

commented Apr 5, 2018

While it probably shouldn't upgrade Go for you if you import something that requires a newer version, vgo could at least tell you right away about the incompatibility and which version you need to upgrade to, rather than you having to guess it from compile errors. I imagine this as just another dependency entry in the go.mod, like this: require "go" v1.11.0.

@gopherbot gopherbot added this to the Proposal milestone Apr 5, 2018

@gopherbot gopherbot added the Proposal label Apr 5, 2018

@jimmyfrasche

This comment has been minimized.

Copy link
Member

commented Apr 5, 2018

Duplicate of #23969

@ALTree

This comment has been minimized.

Copy link
Member

commented Apr 6, 2018

Yep, dup. Closing here in favour of the old thread.

@ALTree ALTree closed this Apr 6, 2018

@golang golang locked and limited conversation to collaborators Apr 6, 2019

Sign up for free to subscribe to this conversation on GitHub. Already have an account? Sign in.
Projects
None yet
4 participants
You can’t perform that action at this time.