Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

x/vgo: vgo requires go 1.10 but VGOROOT=… is not a valid Go 1.10 source tree #24969

Closed
NobbZ opened this issue Apr 20, 2018 · 6 comments

Comments

@NobbZ
Copy link

commented Apr 20, 2018

What version of Go are you using (go version)?

$ vgo version
vgo requires Go 1.10 but VGOROOT=/usr/lib/go-1.10 is not a Go 1.10 source tree
$ go version
go version go1.10.1 linux/amd64

Does this issue reproduce with the latest release?

This is directly after go get -u golang.org/x/vgo

What operating system and processor architecture are you using (go env)?

GOARCH="amd64"
GOBIN=""
GOCACHE="/home/nmelzer/.cache/go-build"
GOEXE=""
GOHOSTARCH="amd64"
GOHOSTOS="linux"
GOOS="linux"
GOPATH="/home/nmelzer/go"
GORACE=""
GOROOT="/usr/lib/go-1.10"
GOTMPDIR=""
GOTOOLDIR="/usr/lib/go-1.10/pkg/tool/linux_amd64"
GCCGO="gccgo"
CC="gcc"
CXX="g++"
CGO_ENABLED="1"
CGO_CFLAGS="-g -O2"
CGO_CPPFLAGS=""
CGO_CXXFLAGS="-g -O2"
CGO_FFLAGS="-g -O2"
CGO_LDFLAGS="-g -O2"
PKG_CONFIG="pkg-config"
GOGCCFLAGS="-fPIC -m64 -pthread -fmessage-length=0 -fdebug-prefix-map=/tmp/go-build230138715=/tmp/go-build -gno-record-gcc-switches"

vgo env fails the same way as vgo version fails.

What did you do?

vgo build, vgo env, vgo version and others. I've only found vgo help to work among the commands I use daily…

What did you expect to see?

A working compiler.

What did you see instead?

vgo requires Go 1.10 but VGOROOT=/usr/lib/go-1.10 is not a Go 1.10 source tree
@gopherbot gopherbot added this to the vgo milestone Apr 20, 2018
@AlexRouSg

This comment has been minimized.

Copy link
Contributor

commented Apr 20, 2018

dupe of #24773

Issue is that where you are getting go from is not including all the files required by vgo.

From #24773 (comment) you can try the following commands or download go directly from https://golang.org/dl/

sudo mkdir /usr/lib/go-1.10/api
sudo touch /usr/lib/go-1.10/api/go1.10.txt
@NobbZ

This comment has been minimized.

Copy link
Author

commented Apr 20, 2018

Haven't seen that other issue. Thank you, will try to manually install.

@NobbZ

This comment has been minimized.

Copy link
Author

commented Apr 20, 2018

Will official go docker containers be sufficient to run vgo?

@AlexRouSg

This comment has been minimized.

Copy link
Contributor

commented Apr 20, 2018

I'm not entirely sure, but I assume they are using the same releases as on https://golang.org/dl/

@NobbZ

This comment has been minimized.

Copy link
Author

commented Apr 20, 2018

Okay, I'll see it when I try to deploy (which will probably not be today) ;) Thank you!

@bcmills

This comment has been minimized.

Copy link
Member

commented Jun 6, 2018

Closing as dup per #24969 (comment).

@bcmills bcmills closed this Jun 6, 2018
@golang golang locked and limited conversation to collaborators Jun 6, 2019
Sign up for free to subscribe to this conversation on GitHub. Already have an account? Sign in.
Projects
None yet
4 participants
You can’t perform that action at this time.