Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

x/vgo: get module@version ignoring @version #25542

Closed
rsc opened this issue May 24, 2018 · 3 comments

Comments

@rsc
Copy link
Contributor

commented May 24, 2018

This works:

$ mkdir /tmp/zz1
$ cd /tmp/zz1
$ echo package m > m.go
$ vgo get github.com/gobuffalo/uuid@v2.0.0
$ cat go.mod
module m

require github.com/gobuffalo/uuid v0.0.0-20180207211247-3a9fb6c5c481
$

But somehow not if there's already a go.mod line for v1.2.0.

$ echo module m > go.mod
$ echo require github.com/gobuffalo/uuid v1.2.0 >>go.mod
$ vgo get github.com/gobuffalo/uuid@v2.0.0
vgo: resolving import "github.com/gobuffalo/uuid"
vgo: finding github.com/gobuffalo/uuid (latest)
vgo: adding github.com/gobuffalo/uuid v1.2.0
$ cat go.mod
module m

require github.com/gobuffalo/uuid v1.2.0
$

Should fix that.

@rsc rsc added this to the vgo milestone May 24, 2018

@gopherbot

This comment has been minimized.

Copy link

commented May 25, 2018

Change https://golang.org/cl/114735 mentions this issue: cmd/go/internal/mvs: fix get module@version ignoring @version

@karux

This comment has been minimized.

Copy link

commented Jun 10, 2018

vgo get github.com/satori/go.uuid@latest does not grab head, but grabs v1.2.0, which is an older commit. How do I grab a specific commit in an external repo?

@kyroy

This comment has been minimized.

Copy link
Contributor

commented Jun 10, 2018

You can use vgo get github.com/satori/go.uuid@master

@golang golang locked and limited conversation to collaborators Jun 12, 2019

Sign up for free to subscribe to this conversation on GitHub. Already have an account? Sign in.
Projects
None yet
4 participants
You can’t perform that action at this time.