Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

x/net/http2: remove support for Go 1.8 and earlier #26302

Closed
bradfitz opened this issue Jul 9, 2018 · 5 comments
Closed

x/net/http2: remove support for Go 1.8 and earlier #26302

bradfitz opened this issue Jul 9, 2018 · 5 comments
Assignees
Milestone

Comments

@bradfitz
Copy link
Contributor

@bradfitz bradfitz commented Jul 9, 2018

Our normal policy for x/* repos is to only support tip and the previous two Go releases.

Once Go 1.11 is out, that means we support tip, Go 1.11, and Go 1.10.

Let's clean up some of all the +build conditional code in x/net/http2 and merge a bunch of the files back together.

Because App Engine is only on Go 1.9, we can be lenient there and support back to Go 1.9.

Verify with grpc & App Engine, though, to make sure we don't break them.

@bradfitz bradfitz added the NeedsFix label Jul 9, 2018
@bradfitz bradfitz added this to the Go1.12 milestone Jul 9, 2018
@bradfitz bradfitz self-assigned this Jul 9, 2018
@bradfitz

This comment has been minimized.

Copy link
Contributor Author

@bradfitz bradfitz commented Jul 10, 2018

@dfawley, what is your schedule or rationale for when and how you move grpc-go's minimum Go version? Looks like you still support Go 1.6 (as we kinda do, except for our tests started to accidentally require Go 1.7+?). But you're moving to Go 1.7? Would you be fine with Go 1.9, now that App Engine defaults to Go 1.9?

@dfawley

This comment has been minimized.

Copy link

@dfawley dfawley commented Jul 10, 2018

I would defer to the AppEngine team (cc @broady) on this one. We were ready to drop support for 1.6 many, many months ago, but kept it in at their request. My preference would be to only support the same versions that are supported by Go (so, 1.9 & 1.10 now), and require users to vendor/use vgo in order to keep using older Go versions.

@broady

This comment has been minimized.

Copy link
Member

@broady broady commented Jul 10, 2018

/cc @light @tbpg @jba @jadekler

Currently supported versions on GAE:

go1, go1.9, go1.8, and go1.6

1.9 is now the default.

@bradfitz

This comment has been minimized.

Copy link
Contributor Author

@bradfitz bradfitz commented Oct 11, 2018

21 more days...
https://groups.google.com/forum/#!topic/google-appengine-go/wHsYtxvEbXI

We’re writing to let you know that we are deprecating Go 1.8 support on App Engine, and new deployments using this language version will no longer be available on November 1, 2018.

Edit: somebody sent me this countdown: https://www.timeanddate.com/countdown/generic?iso=20181101T00&p0=3399&msg=Go+1.6+%26+1.8+Deprecation&font=sanserif&csz=1

@gopherbot

This comment has been minimized.

Copy link

@gopherbot gopherbot commented Oct 29, 2018

Change https://golang.org/cl/145677 mentions this issue: http2: remove support for Go 1.8 and earlier

@golang golang locked and limited conversation to collaborators Nov 1, 2019
Sign up for free to subscribe to this conversation on GitHub. Already have an account? Sign in.
Projects
None yet
Linked pull requests

Successfully merging a pull request may close this issue.

None yet
4 participants
You can’t perform that action at this time.