Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

cmd/go: build fails when setting linker to lld using ldflags [1.11 backport] #27293

Closed
gopherbot opened this issue Aug 28, 2018 · 2 comments

Comments

Projects
None yet
2 participants
@gopherbot
Copy link

commented Aug 28, 2018

@ianlancetaylor requested issue #27110 to be considered for backport to the next 1.11 minor release.

@gopherbot please backport to 1.11

@gopherbot

This comment has been minimized.

Copy link
Author

commented Sep 7, 2018

Change https://golang.org/cl/134057 mentions this issue: cmd/link: don't pass all linker args when testing flag

gopherbot pushed a commit that referenced this issue Sep 11, 2018

cmd/link: don't pass all linker args when testing flag
Some linker flags can actually be input files, which can cause
misleading errors when doing the trial link, which can cause the
linker to incorrectly decide that the flag is not supported, which can
cause the link to fail.

Fixes #27510
Updates #27110
Updates #27293

Change-Id: I70c1e913cee3c813e7b267bf779bcff26d4d194a
Reviewed-on: https://go-review.googlesource.com/134057
Run-TryBot: Ian Lance Taylor <iant@golang.org>
TryBot-Result: Gobot Gobot <gobot@golang.org>
Reviewed-by: Lynn Boger <laboger@linux.vnet.ibm.com>
Reviewed-by: Damien Neil <dneil@google.com>
@ianlancetaylor

This comment has been minimized.

Copy link
Contributor

commented Sep 12, 2018

This is an uncommon case and the change that fixed #27110 introduced a bug. Let's not backport the change.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.