Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

cmd/go: 'go get github.com/Azure/azure-sdk-for-go@v5.0.0-beta' silently gets 'v20.1.0' instead #27627

Closed
bcmills opened this issue Sep 11, 2018 · 2 comments

Comments

Projects
None yet
2 participants
@bcmills
Copy link
Member

commented Sep 11, 2018

Found while investigating #27457.

$ cd $(mktemp -d)

$ go mod init example.com
go: creating new go.mod: module example.com

$ go get github.com/Azure/azure-sdk-for-go@v5.0.0-beta

$ go list -m all
example.com
github.com/Azure/azure-sdk-for-go v20.1.0+incompatible

$ go version
go version go1.11 linux/amd64

$
@thepudds

This comment has been minimized.

Copy link

commented Oct 6, 2018

@bcmills I don’t know if you’ve had a chance to look at this much yet, but do you have an initial guess or sense of what might be going on here, or maybe a guess around possible correlating factors, etc.?

@bcmills

This comment has been minimized.

Copy link
Member Author

commented Dec 12, 2018

The underlying cause here is the same as #29121: if the requested package isn't found in the requested version, we're falling back to latest instead of emitting an error as we should.

@bcmills bcmills closed this Dec 12, 2018

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.