New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

cmd/go: "unknown revision" error followed by "error loading module requirements" #29374

Open
liu-xuewen opened this Issue Dec 21, 2018 · 3 comments

Comments

Projects
None yet
5 participants
@liu-xuewen
Copy link

liu-xuewen commented Dec 21, 2018

What version of Go are you using (go version)?

$ go version
go version go1.11 linux/amd64

Does this issue reproduce with the latest release?

yes

What operating system and processor architecture are you using (go env)?

go env Output
$ go env


image

What did you do?

What did you expect to see?

resolve this bug? auto skip the missing version of module requirements

What did you see instead?

@liu-xuewen

This comment has been minimized.

Copy link

liu-xuewen commented Dec 21, 2018

image
image

@oiooj oiooj added the modules label Dec 21, 2018

@agnivade

This comment has been minimized.

Copy link
Member

agnivade commented Dec 21, 2018

Hi @liu-xuewen - please kindly fill the complete issue template. We need instructions on how to reproduce this issue. The screenshots have been redacted so we don't know what is going on.

auto skip the missing version of module requirements

Why do you expect this to be the behavior ? go build is supposed to build exactly what is specified in go.mod. If there is a mismatch, it should throw an error like shown above.

@thepudds

This comment has been minimized.

Copy link

thepudds commented Dec 27, 2018

Hi @liu-xuewen, in addition to the information that @agnivade asked for, some other quick questions:

  1. What version of git are you using? Old versions of git can trigger an error like you are seeing.

  2. Does a basic example work for you like: https://github.com/golang/go/wiki/Modules#quick-start

  3. For diagnostic purposes, you might also want to try with Go 1.12 beta, which in many cases will print better diagnostic error messages.

    The easiest way to try go1.12beta1 is by using the go command:

$ go get golang.org/dl/go1.12beta1 
$ go1.12beta1 download 

@thepudds thepudds changed the title unknown revision error loading module requirements cmd/go: "unknown revision" error followed by "error loading module requirements" Dec 27, 2018

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment