Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

site: https://golang.org/doc/install incorrectly lists minumum kernel version for linux/arm as 2.6.23 #30559

Open
davecheney opened this issue Mar 4, 2019 · 2 comments

Comments

@davecheney
Copy link
Contributor

commented Mar 4, 2019

https://golang.org/doc/install states that the minimum kernel version for all linux platform is 2.6.23. This is not correct. The minimum for linux/arm is 2.6.27 (possibly 28), however this contradicts information from the wiki, https://github.com/golang/go/wiki/Linux

See #3897

See also https://codereview.appspot.com/7225047/

@ALTree

This comment has been minimized.

Copy link
Member

commented Mar 4, 2019

The minimum requirements page seems to offer an explanation:

Linux/ARMv5 requires much newer kernels, at least v3.1 (for __kuser_cmpxchg64).

https://github.com/golang/go/wiki/MinimumRequirements

Not claiming this is correct, just noting this here so if we uniform the docs one way or the other we can update every place at once.

@davecheney

This comment has been minimized.

Copy link
Contributor Author

commented Mar 4, 2019

@ALTree see #3897, i'd forgotten that we'd tried to address this yonks ago.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
2 participants
You can’t perform that action at this time.