Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

x/mobile: [doc] Go 1.10 or newer is required #30731

Open
bronze1man opened this Issue Mar 11, 2019 · 3 comments

Comments

Projects
None yet
4 participants
@bronze1man
Copy link

bronze1man commented Mar 11, 2019

What version of Go are you using (go version)?

$ go version
go version go1.9.7 darwin/amd64

Does this issue reproduce with the latest release?

No. I do not test the latest release.

What operating system and processor architecture are you using (go env)?

go env Output
$ go env
GOARCH="amd64"
GOBIN=""
GOEXE=""
GOHOSTARCH="amd64"
GOHOSTOS="darwin"
GOOS="darwin"
GOPATH="/Users/a/go"
GORACE=""
GOROOT="/usr/local/go"
GOTOOLDIR="/usr/local/go/pkg/tool/darwin_amd64"
GCCGO="gccgo"
CC="clang"
GOGCCFLAGS="-fPIC -m64 -pthread -fno-caret-diagnostics -Qunused-arguments -fmessage-length=0 -fdebug-prefix-map=/var/folders/m9/qtbxkp6s3p96fk54rln7qhj80000gp/T/go-build131413475=/tmp/go-build -gno-record-gcc-switches -fno-common"
CXX="clang++"
CGO_ENABLED="1"
CGO_CFLAGS="-g -O2"
CGO_CPPFLAGS=""
CGO_CXXFLAGS="-g -O2"
CGO_FFLAGS="-g -O2"
CGO_LDFLAGS="-g -O2"
PKG_CONFIG="pkg-config"

What did you do?

./bin/gomobile build -target=android golang.org/x/mobile/example/basic

What did you expect to see?

ask me to run gomobile init

What did you see instead?

./bin/gomobile: Go 1.10 or newer is required

Ps

https://github.com/golang/mobile/blob/master/README.md says it need This is early work and installing the build system requires Go 1.5.

https://github.com/golang/go/wiki/Mobile says Note: You need to have Go 1.5 or above to install mobile tools. (Or at least Go 1.7.4 if using macOS Sierra)

From the document I think go1.9 can use the lasted version of gomobile.

@gopherbot gopherbot added this to the Unreleased milestone Mar 11, 2019

@gopherbot gopherbot added the mobile label Mar 11, 2019

@karalabe

This comment has been minimized.

Copy link
Contributor

karalabe commented Mar 11, 2019

Any particular reason for not using Go 1.12? The 1.9.x family is not supported any more by the Go team per Go's release policy, so it might make more sense to upgrade?

@bronze1man

This comment has been minimized.

Copy link
Author

bronze1man commented Mar 11, 2019

Any particular reason for not using Go 1.12? The 1.9.x family is not supported any more by the Go team per Go's release policy, so it might make more sense to upgrade?

This is a document problem. The document is wrong.

I will not stay at go1.9.7 forever. I may try to upgrade to go1.12 once I solve all the problem when I upgrade:

  • go1.12 have compatibility problem with my code, As I use syscall.Setrlimit on darwin, go1.9.7/go1.11 works, go 1.12 not. #30401
  • go 1.11 compile slow with cgo/android then go1.9 when I only change one line of one my cgo package.(1min vs 10s) (I have reported this issue, but I can not find it any more) I do not verify this again on go1.12 .
@mvdan

This comment has been minimized.

Copy link
Member

mvdan commented Mar 11, 2019

This indeed sounds like a doc issue; in general, the x repos only support the latest two major Go versions. That would be 1.11 or later as of today's master branch.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.